Realm Cloud Databse - Realm Studio

Hello everyone. I am new to Mongo Db and Realm- I am helping a team with a mobile app.
The app set up with a Realm Cloud project and I need to have access to the database, I have tried to use the Real Studio but there is no more Connect to Cloud project button.

Any idea of how can I see or query the Realm Cloud Database?


Hi Miguel,

Thanks for creating your first post and welcome to the community!

If you are developing a new MongoDB Realm app, this works by connecting to an Atlas Cluster which is where your database can be queried.

If you already have an Atlas cluster linked to your Realm app and want to query data in your cluster, you’ll need to be given a relevant user role on the project that contains the cluster before you can view documents.

I have tried to use the Real Studio but there is no more Connect to Cloud project button.

I believe you’re referring to the functionality of an older version of the Studio which allowed you to connect to the legacy Realm app server. The newer version of Realm Studio does not have this connect to cloud button as it is meant to only allow accessing local Realm files for troubleshooting purposes.

If you are migrating an existing legacy Realm app to MongoDB Realm, please refer to this article for guidance.


1 Like

Hi @Miguel_Olvera , note that you can also use Realm Studio to connect to local Realm databases. This article explains how to use it with iOS apps.


Thanks for the answer but that only opens local files forma single device/user.

I want to access the complete Realm Database.


Hello Mansoor.

Is there any functionality that I can use to do these. Where can I access the legacy Realm database on the cloud?

Is the solution to migrate to Mongo DB?

@Miguel_Olvera Yes, using MongoDB Realm Sync to consolidate all of the data into a MongoDB Atlas database would be the way to view all of the data in one place.

@Miguel_Olvera You can find older Studio Releases here:

For instance, 5.0.3 should allow you to connect to legacy Realm Cloud

Should have mentioned that tried using it but MacOs Catalina doesn’t allow the software to run .


Welcome @Miguel_Olvera

You may already be aware but allow me to provide a high-level overview which may or may not help.

I don’t think it was mentioned but when Realm became MongoDB Realm, the strategy for setting up and working directly with the database also changed. Previously you would access both local and Realm Cloud realms with Realm Studio. That App is now for local only.

Going forward (and once the data is migrated), you need to use the online MongoDB Console to set up your app and work directly with all of the Realm data. This is the login link.

Secondly, Realm is a local first database. That means that what is stored in the Realm Cloud may be a copy of the data that is stored locally (data is written locally first and then sync’d later). So you can use Realm Studio to access the local data.

However, legacy came in two flavors; Full Sync and Partial (or query) Sync. If that was set up as full sync, all of your data is local and what’s in the cloud is just a copy. If it was partial, you will need to go through a different process. You didn’t mention which is was.

If you need to use Realm Studio 5.0.3 and are running Catalina, you can run older versions of macOS (and apps) using VirtualBox.

Keep in mind that if you do open a prior Realm file with Realm Studio, it will force an upgrade to the file which means it won’t be compatible with an older SDK, so you end up updating that as well.

Loop us in if you have more questions.

1 Like