Realm CLI Login Failure

Hi there all,

I am having consistent issues with logging into my app via the realm-cli. I am using the following command:

realm-cli login --api-key="API_Public_Key" --private-api-key="API_Private_Key"

I’ve tried it a bunch of ways (with quotes, no quotes, with = without =) and always get the same result:

“login setup failed: unsupported login type, use one of [cloud, local] instead”

I’ve verified here: Organization Access Manager/API keys that my keys are listed as 'organizational owner"

Can anyone point me how to fix this of what i’m doing wrong? Thanks so much!

Ok folks, looks like I figured this one, it seems to be a problem with the most recent version of the CLI. I downgraded to 2.3.3. and all is fine. Just a heads up for the community!

Same problem but I’m on already 2.3.3. Can you confirm what version is working for you?

Hit same issue. realm-cli version 2.3.3. This is following step 13 of the testtracker app tutorial setup here

This command fixed it for me---->npm install -g mongodb-realm-cli@1.3.4. Let me know if it works for you!

The notes in the tutorial mention using version 2 of cli.

Realm CLI Version Compatibility

This tutorial is compatible with version 2 of realm-cli . If you already have the CLI installed, check your version to make sure that it’s compatible with this tutorial.

npm install -g mongodb-realm-cli@2.0.0
Let me know if it works for you!

1 Like

Thanks, that hepled!