Realm App Hosting: cannot upload files, incorrect directory, files not found

I am doing this tutorial

Here is my repo

When I push on my repo it is deployed, however it is not deploying the index.html and data.js in the root directory.

I am unable to manually upload the two files because the Upload button is grayed out and some error messages are displayed, as seen in this image:

I can view the files are working correctly (querying Atlas) using Live Server, however the files are not picked up by the Realm dashboard and are not deployed to the URL

I am seeing this error at the hosting URL

404 Not Found
Code: NoSuchKey
Message: The specified key does not exist.
Key: 61f057f63bf82311ace9b3a7/index.html
RequestId: 477SBZEXBNXR5V0Z
HostId: lNaJZFETHfR9ctR41NOdUUtwI5/aHQR5DyScDFb6cuRGgeBVtHZcqjqVjOoR0qSKAjOVoVh2rh4=

I am able to deploy on GitHub pages

I’m having this same issue. Did anybody solve it yet?

I solved it! The app I was hosting was a React app. On the Realm Hosting page, I had to go into settings, select “Single-Page App”, and the select “index.html”. Then everything worked.


Thank you so much @Beau_Carnes. This solved the problem. I followed your tutorial to learn the MERN stack, I built the app. Then when I tried deploying the react app, it was not working after trying and trying to resolve this issue for hours I started looking on internet still nothing and somehow got here.

Thanks you for both the tutorial and the solution :>