Realm 10.0.0-beta.3 SSL error on call to Realm.GetInstanceAsync(config)

Upgrading from realm dotnet 10.0.0.beta.2 to beta.3, application fails on call to

“SSL Server certificate rejected”

Interesting - just to confirm, are you using it with MongoDB Realm (asking because the tag says legacy-realm-cloud which is the one hosted on

Yes it’s MongoDB realm. I just upgraded from 10.0.0-beta.2 to beta.3.
I seem to have lost the link to the 10.0.0 forum.

This occurs using Credentials.EmailPassword Authentication.
I switched to anonymous connection and get the same result.

What platform are you seeing this exception on? Also, are you by any chance behind some corporate proxy/firewall that does its own SSL termination?

All on a home standard network.
On iMac, Parallels Windows 10, Mcaffee .
Never had a problem before beta.3.

I published the app and ran it on a standard Windows 10 PC.
Same result. SSL rejected.

Thanks, I was able to reproduce it - we’ll look into hotfixing that, but for now my suggestion would be to downgrade to 10.0.0-beta.2.

I filed realm-core/4213 to track resolving it.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.