querySrv ENOTFOUND _mongodb._tcp.cluster0-shard-00-00-jxeqq.mongodb.net

Hello Folks, need help resolving this error. Can’t connect to the database set up for the class. Installed Compass 1.19.12.

I read other posts for this issue.
I can ping to http://portquiz.net:27017
nc -v portquiz.net 27017 Connection to portquiz.net 27017 port [tcp/daytime] succeeded! curl portquiz.net:27017
Port 27017 test successful!

Although, can’t ping below -
ping cluster0-shard-00-00-jxeqq.mongodb.net

This site can’t be reached

cluster0-shard-00-00-jxeqq.mongodb.net took too long to respond.

I’m taking this class from home. I’m not on VPN and using Norton firewall. Turned off the firewall and still can’t ping cluster0-shard-00-00-jxeqq.mongodb.net.

Appreciate any help!

Have you whitelisted your IP?
May be it is a temporary N/W issue
Are you able to connect by shell?
I you are unable to ping server itself means firewall issues
Try another internet source like your mobile hotspot and see

Hello Ram!
I’m not sure what do you mean by whitelisting the IP. Can you please tell me how to do it?
I don’t know how to connect using shell. Just started with MongoDB basic class.
I tried hotspot and still the same.



Whitelisting allows you to connect from anywhere
You will come to know about this in Sandbox cluster setup
You can connect to mongodb from Compass or command line
By shell i meant connect from command line using below command
If you are using Windows run at cmd prompt
If you are using vagrant Unix box run at unix prompt

mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/test?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

First you need to identify why your ping is failing to Class cluster

Hi @Mukesh_46936,

As you have mentioned, connecting from your mobile hotspot did not resolve the issue. It could be the firewall/anti-virus on your machine which is blocking the request.

Please try to disable the anti-virus for some time and see if that resolves the issue. If it does not resolve the issue then try to connect from some other system.

Hope it helps!

If the issue still persists, please feel free to get back to us.

Shubham Ranjan
Curriculum Support Engineer

Hello! Thank you for your help! I’m able to connect now. Now sure if it was a temporary glitch.