"pytest -m user_management" not running properly


When I run the command “pytest -m user_management” on the cmd (having the conda environment activated an having the working directory on the proper place) I get the next message:

============================= test session starts =============================
platform win32 – Python 3.7.0, pytest-3.8.0, py-1.6.0, pluggy-0.7.1
rootdir: C:\Users\ruben\Desktop\Carpetas\Estudios\mflix-python, inifile:
plugins: remotedata-0.3.0, openfiles-0.3.0, flask-0.10.0, doctestplus-0.1.3, arraydiff-0.2
collected 35 items / 35 deselected

======================== 35 deselected in 0.55 seconds ========================

What I expect is the number of errors and warnings, as the modifications I did for the User Management Ticket are not running.

Is there something I’m missing?
Thank you!

I think file needs to be renamed in the tests folder. The original file had ~beta release appended to the end. I just renamed to test_user_management.py and it worked.

1 Like

Yes, that was the problem! It worked after renaming it.
Thank you!

1 Like

You may want to re-download the course materials as many more of the tests have this same issue. And I encountered at least one that contained different code than the beta/HEAD versions.