Problem with wrong data?

Unit test is failing due to a mismatch in values…testMoviesCount(); I’m returning 23,539 when I should be returning 45,993. I manually checked my database to verify count and found that there in fact is 23,539 documents in the movie collection. Not sure what to do here…Also, test failing for connection ticket.

I have the same “problem” after loading the sample dataset in.

I’ve tried with the MongoDb sample_dataset and with the dataset that I cloned from the repository. Neither worked for me. Both contain 23,539 documents in the movie collection.

Hi @Roger_39802,

You are correct. You have the right count of documents.

I believe the zip file for the course is outdated. Please download it m220/ again.

Let me know if you are still facing issue.


Thank you Kanika…but I downloaded the file in the link and still got the same number of documents for the movie collection

I have the same problem. There are 23,539 documents in the movies collection. No matter if I pull from github or extract any of the zip archives or load the sample dataset! Only the db name is different every time. Can this be fixed? How am I supposed to continue with the course?

Hi @Roger_39802, @olaf.staehle,

The data you have imported is correct. Please use the Handout zip file only to continue the course. The test files have been updated.


I was one of the foolish guys who forked it from git and imported it that way, is it a outdated method for now ? go for pure handout(zip from teacher) ?

Thank you Kanika. Issue resolved. Connection test passing.

1 Like

Hi @gudmundurb,

You are not foolish! Please share the git link here so that we can take a look and if our team is responsible for the git, we will update it! :slight_smile:


Thanks for the tipp Kanika, works for me too! :smiley:

1 Like