Problem running vagrant on opensuse

Hi people,

I can no longer run the vagrant up command after I restarted my pc. I have the following error message:

Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Clearing any previously set network interfaces…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“hostonlyif”, “create”]

Stderr: 0%…
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to create the host-only adapter
VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage: error: Context: “RTEXITCODE handleCreate(HandlerArg*)” at line 94 of file VBoxManageHostonly.cpp

Can anybody help me?

Hi @Aramis,

The possible solution to this issue is to disable the secure boot on your machine.

Below are the steps listed to disable secure boot:

  • Click simultaneously the shortcut Restart + Shift key.
  • Click Troubleshoot → Advanced options → Start-up Settings → Restart.
  • Click repeatedly the F10 key (BIOS setup), before the “Startup Menu” opens.
  • Go to Boot Manager and disable the option Secure Boot. …
  • Save the changes and reboot.

Please let me know if the issue still persists.

Curriculum Support Engineer

Hi Muskan,

I changed to UEFI Secure boot OFF but still the error persists.


Following are the commands I ran to solve the problem:

sudo ‘/sbin/vboxconfig’

Sources for building host modules are not present,
Use ‘sudo zypper install virtualbox-host-source kernel-devel kernel-default-devel’ to install them. Quitting …

sudo zypper install virtualbox-host-source kernel-devel kernel-default-devel

Verificando por conflito de arquivos: …[concluído]
(1/1) Instalando: virtualbox-host-source-6.0.14-499.1.noarch …[concluído]

sudo ‘/sbin/vboxconfig’
virtualbox-host-source package version doesn’t match the version of virtualbox package.
This situation is probably not fatal, thus we will try to continue …
Building kernel modules…
Kernel modules built correctly. They will now be installed.
insmod /lib/modules/5.2.14-1-default/misc/vboxdrv.ko
insmod /lib/modules/5.2.14-1-default/misc/vboxnetflt.ko
insmod /lib/modules/5.2.14-1-default/misc/vboxnetadp.ko
insmod /lib/modules/5.2.14-1-default/misc/vboxpci.ko
Kernel modules are installed and loaded.

vagrant up

Now it works.


Hi @Aramis,

Good to hear that you were able to figure out a solution.

Please let us know if you face any other issues.

Curriculum Support Engineer