Problem running the command: "vagrant up"

Hi Everyone, After installing Vagrant, I tried to run the command “vagrant up” in order to power on the VM, I got this log with errors:

Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Clearing any previously set forwarded ports…
==> mongod-m103: Clearing any previously set network interfaces…
==> mongod-m103: Preparing network interfaces based on configuration…
mongod-m103: Adapter 1: nat
mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports…
mongod-m103: 22 (guest) => 2222 (host) (adapter 1)
==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “2bef7ec4-5158-43fe-8d01-1e15e9905c83”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: The native API dll was not found (C:\WINDOWS\system32\WinHvPlatform.dll) (VERR_NEM_NOT_AVAILABLE).
VBoxManage.exe: error: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

Can any one have an idea about the origin of the error ?
Thank you.

Please check if this helps
Also check other threads on vagrant up

Error during: Vagrant up

Hi @Billel_64570,

In addition to @Ramachandra_37567’s post, you can also follow the Lecture: Troubleshooting the Vagrant Environment for this issue.
Please find the screenshot for your reference:

Please let me know if you have any questions.


For the life of me, I cannot get Vagrant to start up. I have tried everything. I enabled virtualization in the BIOS. I turned off Hyper-V. I have modified the Vagrantfile to include login and password details. I have rechecked the installation versions and I can’t get it to work. The latest attempt to run ‘vagrant up --provision’ gives me a 'CP720 (Argument Error) with a full list of callback information after that. What am I doing wrong? This has become most frustrating!

Hi @Brandon_48087,

Kindly refer to the following thread and see if you can find a solution - Vagrant up not working

Please get back if this doesn’t work for you.
Happy to help!

Curriculum Support Engineer

Okay…so I finally made some progress. I was able to provision and utilize the vagrant ssh. I can now see the vagrant@m103:~$ prompt. However, when I try and run the ‘validate_box’ command, I get the “command not found error message”

Side note: I also tried changing the “sudo apt-get…” key command in the provision file and re-provisioned vagrant, and I still receive a “command not found” error. It is now day three, and I still can’t get passed the first lab. Very frustrating.

Hi @Brandon_48087,

Please follow the below the given thread for reference, it might be helpful.

Curriculum Support Engineer