Private endpoint greyed out

Hi,

I am trying to setup Private endpoint to atals plane use Azure private link service. The private endpoint is becomes available in status however when trying to connect from connect plan, it is seen as greyed out. Have anyone faced this issue?

Hi @Mithun_Pillai2,

Welcome to the community :slight_smile:

Can you provide the following information regarding the project that you attempted to connect via Private Link?

  • Cluster tier
  • Standard replica set or sharded cluster
  • Single or multi region cluster
    • if multi, please state the regions that the nodes are situated in
  • The region(s) in which the private link services were provisioned

Kind Regards,
Jason

1 Like

Hi @Jason_Tran ,

  • Cluster tier – M10
  • Standard replica set or sharded cluster --3 Node replica set
  • Single or multi region cluster – Multi Region
    • if multi, please state the regions that the nodes are situated in (GermanyWestCentral & GermanyNorth)
  • The region(s) in which the private link services were provisioned–Same region as above.

2 Nodes in GermanyWestCentral and 1 in GermanyNorth. Private endpoint created in GermanyWestCentral region.

As I said earlier, I am able to create private endpoints but when trying to connect using Private Endpoint it is greyed out.

Thanks in advance

Kind Regards
Mithun

Thanks @Mithun_Pillai2,

2 Nodes in GermanyWestCentral and 1 in GermanyNorth. Private endpoint created in GermanyWestCentral region.

As per the limitations for Azure Private Link, Azure Private Link must be active in all regions into which you deploy a multi-region cluster.

Can you try establishing azure private link services for all regions in which your nodes exist? i.e. for your 2 region cluster, create 2 azure private link services (1 for germanywestcentral and 1 for germanynorth)

Kind Regards,
Jason

1 Like

Hi @Jason_Tran,

I tried creating Azure Private link in both the regions from the same VNET in germanywestcentral location. The first endpoint created but the second is failing.

Or my interpretation is wrong. I need to Create Azure private link between same Azure vnet region and Atlas region.

Hope you understand what I am trying to explain.

thanks,
Mithun

Hi @Mithun_Pillai2,

The first endpoint created but the second is failing.

  1. Are you getting any errors for the second endpoint that is failing to create?
  2. Is the error you’re receiving seen on Atlas or Azure?
  3. What region are you attempting to create the second endpoint?

Regards,
Jason

Hi @Jason_Tran

Are you getting any errors for the second endpoint that is failing to create? --yes
2. Is the error you’re receiving seen on Atlas or Azure?- -On Atlas. Deploying your changes failed; we will try again shortly.
3. What region are you attempting to create the second endpoint? germanynorth.

Regards,
Mithun

Thanks for sharing that information.

Deploying your changes failed; we will try again shortly.

The above doesn’t provide much information regarding the endpoint creation. However in this scenario, it’s more than likely just indicating that the endpoint service failed to be established so the deployment of changes failed.

  1. What is the Endpoint Status and Atlas Endpoint Service Status?
  2. Have you been able to successfully create this same endpoint in the past for the germanynorth region?
  3. Were there any error messages during the configuration of the endpoint?
  4. If not already done so, try terminate and re-creating the endpoint following this guide.

I suspect that if both Endpoint Status and Atlas Endpoint Service Status are Available for all endpoint services that are linked to the regions your cluster is configured for, the connect modal will not grey out the private link connection option.

Regards,
Jason

1 Like

Hi @Jason_Tran ,

Atlas endpoint service status is available but Endpoint status in Azure is “not connected”. This is the first time we are trying to create endpoints for Atlas. I believe Atlas endpoints should be created on the same region as the VNET’s are present.
I am doing some more research and will update here the outcome. Thanks for your kind help. If you have any more news in this topic please share here.

Regards,
Mithun