Postman, Atlas Data API invalid session error

I’m trying to Update/Post to my documents in an Atlas database through using the Data API via postman, I followed all the steps and filled in all the essential variables and I consistently get that error

invalid session: error finding user for endpoint

Here it shows that I successfully forked the MongoDB Data API to my Postman collection and filled in all the necessary variables

This is me making the POST request to find a document in my database (this same exact error keeps on showing with all the other endpoints, update, insert, etc…)

Capture128

And these are the header and body of the request showing that the variables were correctly setup and the the request is going through with no problems but I get that same error every time .

So I figured it might be a postman thing so I tried to make the request using Python instead and I got the same exact error there too.

This is the document I am trying to send the requests to,

And this is my Data API game with the cluster all being setup and given access for both reading and writing.

So I am not sure what is exactly going on or what am I not seeing

Hi @Amir_Adel and welcome to the community!

Based off the error that’s being generated by postman, I believe this may have to do with an invalid API key being entered. Has the same key worked for your previously?

If not, can you try the testing again using a brand new Data API key?

I was able to reproduce the error on my test environment by providing an incorrect API key.

Please note that I was able to successfully perform the POST request to find a document before purposefully changing the API key to an invalid value:

Regards,
Jason

3 Likes