Possible to connect a GUI shell with the course database?

I find I learn the concepts best when hooked with a GUI interface like the Atlas Finder or Compass. Presently, I can only connect with this course’s database via the Terminal. I tried connecting the database with Compass but to no avail.

Hi @SOO_QUEK , hope you are doing well.
Can you please take a look at our official guide on how to connect via compass?
Hopefully, you will be able to establish a connection between Atlas and Compass after following all the steps mentioned in the guide.

In case you have any doubts, please feel free to reach out to us.

Thanks and Regards.
Sourabh Bagrecha

Believe me, I have tried but to no avail…

Please describe the steps you followed and indicate which one failed.

Sometimes a screenshot that show the issue/error message/warning is worth including.

I input:

“mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

No connection is the feedback.

I used on the Terminal:

mongosh “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

and it worked.

In Compass, password, user name, authentication database have different input fields.

So please

I input the above strings into the box, it refuse to connect. I didn’t input into the fields but it automatically went inside after I tried to connect. Here they are:



Can you suggest what I should input there instead of asking for the system feedback which was Connection Closed…

Have you tried SRV string?
You can connect in different ways i,e using connect string or filling individual fields
For connect string you have long form and SRV
Try this:
From Compass—>connect paste below SRV string into the box and hit connect
mongodb+srv://m121:aggregations@cluster0.jxeqq.mongodb.net/test

3 Likes

Thanks! It worked! Finally!