Port Mappings and Connection on a VM Running Multiple Docker Apps

I have a DigitalOcean ‘Droplet’ (VM) running UBUNTU and NGINX. I’m hosting multiple Apps there…

appname.tjmcode.io 	(:3000 :8080 :27020)
badbank.tjmcode.io 	(:3001 :8081 :27021)
getgrub.tjmcode.io		(:3002 :8082 :27022)

…each App work great mapped to 3000, 8080, 27017.

Each is made up of (3) Docker Containers started with their own docker-compose.yaml.

<appname>-frontend  --> 300x
<appname>-backend --> 808x
<appname>-database --> 2702x

After mapping each App to the new Ports all Containers and their responses work but the ‘backends’ cannot connect to their respective ‘databases’. (i.e.: I can use localhost:300x,808x,2702x for any of them and I get the proper response).

I have tried the following MongoDB Connection Paths to no avail… (where ‘x’ is 0, 1, 2)

mongodb://0.0.0.0:2702x/${APP_NAME}
mongodb://127.0.0.1:2702x/${APP_NAME}
mongodb://localhost:2702x/${APP_NAME} - worked with 27017
mongodb://${APP_NAME}-database:${APP_DATABASE_PORT}/${APP_NAME} -- worked with 27017

Hugely frustrating to spend so much time on a connect statement.