Point in time shard restore getting queued forever

I’m using Mongodb Ops manager 3.6.12, when restoring a shard from a snapshot everything is well, but when I tried to do a “point in time” restore , the job stayed queued forever.
Profiling backupjob.restorejob application db, I see that BackupDaemon is doing a find query and a match is found. But after that nothing happens, no errors in the daemon.log whatsoever even at DEBUG level.
Does anyone know how why BackDaemon is refusing to service the point in time restore job? TIA

"op" : "query",
"ns" : "backupjobs.restorejobs",
"command" : {
	"find" : "restorejobs",
	"filter" : {
		"type" : "restore",
		"groupId" : ObjectId("5ee282ec46e0fb00f28f6274")
	"sort" : {
		"_id" : -1
	"$db" : "backupjobs"
"nreturned" : 1,

Additional info:
When doing PIT recovery on this particular shard, I see no queries being made into OplogStore db, but on a separate shard(ConfigRs) I’ve tested where PIT restoration works, queries are being made.

Upgrading to version 4.0.19 made PIT worked, unfortunately trying to compare the old MMS data and migrated data didnt reveal any obvious reason why it was failing. closing this one

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.