Please explain how to run the m121 labs in induced IDE@Cloud

Greeting to all:)
I am I.Venkat have some challenges to install the MongoDB client/DB in my system due to admin rigths, so trying to run this m121 lab in the seede IDE space bash#, but not able run some commands like load(validateLab1.js) etc…
please advise.
Thank you all in advance.
Have a gr8 day:)


Not an expert, but did you evaluate the possibility of installing a virtual machine?

Also, you could set up an EC2 in AWS, it’s free if you do it with care.

Hi Santiago,
Thank you for the response!.
Yes , i have the Oracle VM installed, but due to some restrictions of Windows OS , i could only install Version 3.4/3.6.Please advise how to use it for the above labs.


Wish I could be of more help. I’ve only used Vbox, and Linux.

What I would try in that situation is to download ubuntu iso from the main ubuntu website (it’s a file with the operative system). And install mongoDB therein, which is very simple.

What I have a hard time understanding is how are you able to install a VM while not being able to install MongoDB shell due to admin rights.

Yes, you are right, then that time the Admin rhists were there and now recently our compnay has revoked for all…


Are you able to download MongoDB Server?

If you are still facing any issues, please feel free to reach out.

Kind Regards,

Hi Sonali,

Since I have the admin rights issue, so , I have installed oracle VM and started windows 7 as guest OS and I could install MongoDB 3.4 version in that m/c. I am able to start the mongod server locally
But the client mongo, I am not able to connect the below command.
Please advise and help so that I can do practice M121 LABS faster.
M121LabsIssue.pdf (292.0 KB)

You are able to connect successfully to your local mongod instance

Your command to connect to aggregations with m121 is correct
I think it is a syntax error due to some space --ssl spilled to next line and that’s where it is throwing error
Try again as i am able to connect without any issues on my Windows


I tried again , but still goes to next line since the command is relatively lengthier …
please advise .

Please paste the command you are using as it is (not screenshot)

Pls see below:
mongo “mongodb://,,” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

I also tried with the option '^; like below, but same issue.
mongo “mongodb://,^
–authenticationDatabase admin --ssl -u m121 -p aggregations --norc

May be some terminal/keyboard issue
I can connect with the connect string you pasted

Try this

mongo “mongodb+srv://”
If you can connect then switch to the desired DB

What is the issue in using your IDE?
I am not clear what issue you are facing

Hi Ramchandra,
Thank you for the responses!
Still no luck… my IDE works fine but it sessions out frequently and every time i have use the connection string and start from the beginning.

What is the exact error you are getting with new connect string.There is no --ssl in this
Please show screenshot


Please try without quotes in the connect string
no digits means some space or fancy quotes in the command which shell does not like

You are mixing SRV style connection with the none-SRV old style connections.

The cluster name, with SRV connections, is

If you spectify something like shard-00-02 you are trying to connect to an host directly. So you must use mongodb:// without the SRV.

Hi Steev,
Pls advise what should be correct full string command.
I have tried the below.

mongo “mongodb://”

Against the original command:
mongo “mongodb://,^
–authenticationDatabase admin --ssl -u m121 -p aggregations --norc