Paste handsout on Cmder terminal

I’m using windows 10 and Cmder as terminal
I have no problem connecting compass and Cmder to cluster, when pasting the handsout on the terminal I get cero inserted files …

During the creating documents…
the command is autocompleting is not clear as it is being explain for macOS

I paste the handsout code on Cmder but I get nothing inserted
please explain it for Cmder or windows terminal…
and I’m so worry as I’m so close to chapter’s deadline


It should work
On which DB you are loading?
check by show collections

Hi Ramachandra

to make sure I’m using the right DB… I’m using
use video command

Then I check for the collections into the video DB and everything work fine, I didn’t undestand the shortcuts to get the doc from the movie collection to copy on the noviesScratch so I typed it all and worked just fine had no problems with the insertOne … I even checked with compass…however with
insertMany… is not working… I try window cms, Cmder and microsoft Visual Studio Code ( … all of them with same results… I can connect to my cluster but can not use the insertOne command

For your information I’m using MongoDB Enterprise Server V4.2.0

Hi Ramachandra

I found 2 notifications on my Bitdefender antivirus… Do you think this could be the reason for the insertMany command not being working for me???

Hi @Jose_20145,

If you look at the error message it says, duplicate key error collection for the very first document that you tried to insert. Can you please make sure the documents hasn’t been inserted already in the collection ?

In MongoDB, you cannot insert two documents in the same collection having the same _id field. When you will execute the query given in the handouts, you are expected to get an error because we have duplicate documents in the list of documents that we are trying to insert using the insertMany() function.

It is very unusual thing to happen. However, I would recommend you to use the cmd for running the mongo shell.

To verify that insertMany() function is working, please execute the below mentioned command from mongo shell.

use dummyDb

If you are not able to execute this command in mongo shell running in cmd then please get back to us.

Happy Learning :slight_smile:

Shubham Ranjan
Curriculum Support Engineer