Outdated babel plugins

For mflix Babel 7 was installed. Preset stages are deprecated for Babel 7. Also now “@babel/preset-env” is used, not “babel-preset-env”. So tests returned with errors. What can I do with this problem?

I don’t know if this is correct, but after doing the following my test for connection passed (I am not sure about all the steps, I hope I don’t miss anything):
I uninstalled all the babel-xy in dev dependencies and then installed their updated versions (@babel/xy), so the babel-part of my package.json dev dependencies now looks like this:
@babel/core”: “^7.3.3”,
@babel/plugin-transform-runtime”: “^7.2.0”,
@babel/preset-env”: “^7.3.1”,
@babel/register”: “^7.0.0”,
@babel/runtime”: “^7.3.1”,

also, as you might see there is no -stage-1 because it threw an error as well, so I just uninstalled it. I don’t know if that will be problematic in the assignments to come, I have only completed one ticket so far.

As for the other changes I made, my .babelrc file looks like this:
“presets”: ["@babel/env"],
“plugins”: ["@babel/transform-runtime"]

and the first line of index.js is changed to

I hope this helps, but again, it might not be correct thing to do since I only got it to work by trying and failing several times, I don’t exactly know what I should have done since I don’t know babel package well at all.

can you share your full package.json file

Error: Requires Babel “^7.0.0-0”, but was loaded with “6.26.3”. If you are sure you have a compatible version of @babel/core, it is likely that something in your build process is loading the wrong version. Inspect the stack trace of this error to look for the first entry that doesn’t mention “@babel/core” or “babel-core” to see what is calling Babel.

I get this error after doing this