Npm start doesn't work

which steps, I tried all the steps mentioned above

You must be missing something, or doing something wrong.
Because followed the same steps and got the application running

Hi @MANJESHA_34722,

This does not seem to be related to babel-register, I would strongly recommend to create a new topic moving on for better support. :slight_smile:

For this issue, please check the connection string in .env file. Please share the contents if you are still getting the issue.

Kanika

1 Like

I know that it is not related to babel-register ,I checked .env file also everything is looking fine , but i still getting this following erorr.

Hey @MANJESHA_34722

Could you share the contents of the .env file. The error you get is usually synonymous with a bad connection string and not babel-register

Please change code in index.js back to

require("babel-core/register")

Actually I see the issue in your screenshot! You have not rename the file to .env yet.
Please follow the instructions listed here

  1. Locate the file called dotenv_win or dotenv_unix (depending on your operating system) and replace the information within with your own srv connection string
  2. Rename dotenv_win or dotenv_unix to .env .
mv dotenv_unix .env  # on Unix
ren dotenv_win .env  # on Windows

Plus please respect what the @Kanika has said and open a new post next time.

1 Like

.env contents

`# Ticket: Connection

Rename this file to .env after filling in your MFLIX_DB_URI and your SECRET_KEY

Do not surround the URI with quotes

SECRET_KEY=super_secret_key_you_should_change
MFLIX_DB_URI=mongodb+srv://m220student:m220password@
MFLIX_NS=sample_mflix
PORT=5000
`

Thank you @MANJESHA_34722

And just as @Kanika said your URI is incorrect. Ill show you my working version and you will see your error.

MFLIX_DB_URI=mongodb+srv://m220student:m220password@mflix-p1ozk.mongodb.net/test?retryWrites=true&w=majority

Notice that you have not completed your connection string with the actually host name, db or options.

Have you created your Atlas cluster? from Chapter 0

see sir i have created.

@MANJESHA_34722

Ok visit the connect tab there near the left and you will find your connection string.

This is laid out in the course\s README.rst file. Where there are pretty picture to help.

Go to your cluster Overview -> Connect -> Connect Your Application.
Select the option corresponding to your local MongoDB version and copy the
mongo connection command.

Hi @MANJESHA_34722,

Let me know if you are still facing the issue.

Kanika

I followed as per README file, that problem is solved , but again i am getting one more error like bad authentication

2

Please check the username and password in .env file.

Kanika

image

this is the one i copied to .env file

Hey @MANJESHA_34722

So you would have to change the <password> part to the correct password. If you followed the steps it would be m220password

Thanku @natac13 and @Kanika now everyhting is fine.

1 Like