Not able to use cp command described in lecture


My vagrant is running properly.

  1. I just installed it and ran “vagrant up” from “D:\university\m103\m103-vagrant-env”. (worked fine)
  2. After that I created directory inside VM using “mkdir -p ~/university/m103/” (worked fine)
  3. After that I used “vagrant@m103:~$ cp -r m103-vagrant-env/ ~/university/m103/” which resulted in following error

vagrant@m103:~ cp -r m103-vagrant-env/ ~/university/m103/ cp: cannot stat 'm103-vagrant-env/': No such file or directory vagrant@m103:~

Please help me on this.

1 Like


Just Ignore this post from me as I was confused between host machine and VM. I just worked through it and everything is fine.

If anyone is looking at it, the problem was I was trying to do the things that he explaining on host machine on VM and that was the reason for the error.

Anyways, Thanks .


@007_jb @Shubham_Ranjan
I have exactly the same problem described in chapter of that topic by Vishal. I don`t know if I need to open new topic with the same problem if the topic is one year old?

I don`t understand where I need to run the command to do the things that he explaining and how to run it?

I tryed to run command: cp -r m103-vagrant-env/ ~/university/m103/ 1. after vagrant up, 2. after vagrant provision, 3.after vagrant ssh , and I understand that I am doing something wrong. Please clarify me that.

@Semion_79117 are you talking about “Lecture: Setting Up the Vagrant Environment”? If yes, then all the steps you’re trying to perform is not required anymore because you have already setup vagrant. You need to continue watching from 5:28.


Hi @Semion_79117,

As @007_jb mentioned, you can safely ignore this step.

Please let us know if you have any other issue.

Shubham Ranjan
Curriculum Services Engineer