Not able to shutdown the server

Following are the commands used to connect mongod

vagrant@m103:~$ mongod --port 30000 --dbpath first_mongod --logpath first_mongod/mongod.log --fork
about to fork child process, waiting until server is ready for connections.
forked process: 4217
child process started successfully, parent exiting

–connectiong to mongoshell
vagrant@m103:~$ mongo --port 30000
MongoDB shell version v3.6.17
connecting to: mongodb://127.0.0.1:30000/?gssapiServiceName=mongodb
Implicit session: session { “id” : UUID(“37732f2d-cacb-4c5f-a4d9-bb006668f714”) }
MongoDB server version: 3.6.17
----when i am trying to shut down the server or create use getting the same error.
MongoDB Enterprise > use admin
switched to db admin
MongoDB Enterprise > db.shutdownServer()
server should be down…
2020-02-26T21:09:23.460+0000 I NETWORK [thread1] trying reconnect to 127.0.0.1:30000 (127.0.0.1) failed
2020-02-26T21:09:23.462+0000 W NETWORK [thread1] Failed to connect to 127.0.0.1:30000, in(checking socket for error after poll), reason: Connection refused
2020-02-26T21:09:23.462+0000 I NETWORK [thread1] reconnect 127.0.0.1:30000 (127.0.0.1) failed failed
MongoDB Enterprise >

Please help me with the above error.

The server is shutdown successfully.

Thanks for your reply.
I tried that command, Server is not shutting down. in the above post i mentioned the error message also

It’s not an error message. It’s just telling you that it’s shutdown and connections are no longer possible. You just need to exit the mongo shell.

You can check using the Linux command:
ps -ef | grep [m]ongo

Or you can try and run show dbs and it will throw an error.

Thanks you so much, my issue is resolved.

Closing this thread as the issue has been resolved.