Not able to select msi in mongoDB download center

Hi, To download the mongo shell after navigating to mongoDB download center I choose:
Version : 4.0.3
OS : Windowsx64x64
package : ZIP, MSI, Shell are visible but unbale to select MSI ?

Could someone please help ?

Hi lavesh_singhal,

When you select Version -> 4.0.3, Operating System-> Windows x64, you will be getting a popup like this:

You have to click on msi link- here and it will start downloading the file.

If you are not able to download the file, please check your firewall settings or try from a different browser.

Thanks, Kanika

1 Like

Thanks Kanika it worked now. Actually I was trying to download it from new Download center. Actually I had to go to old one.
But now during installation I am seeing below error message -

"Service “MongoDB Server (MongoDB) failed to start. Verify that you have sufficient privileges to start system services.”

I have retry that multiple times with no success. Apart from that seen Windows Installer services and made it from Manual to Automatic but still no success.

Appreciate if you can help please ?


On the new download centre, if you pick the shell option, not ZIP or MSI, in the package option, it will download the signed-MSI version.

That really does need fixing, since it is unnecessarily confusing, and wastes time for Windows users.

1 Like

The most important question is: does your account have local administrator rights on the particular system? That’s the very least needed to install and start a new service.

1 Like

The Web site has been fixed, so picking the “MSI” choice in the drop down menu will work now.


1 Like