Not able to download mongo db enterprise

service mongoDb server failed to start

Hi @niloufer_77747,

Please use this link to download MongoDB Enterprise and also plesse make sure you are choosing the right version of the OS .

If the issue still persists, please share the following details:

OS type and it’s version
Web Browser details
Screenshots of the error message that you are getting

Shubham Ranjan
Curriculum Support Engineer

Yes i did try all possible.
And now my laptop has crashed as trying different stuff i deleted my environment variable

I also cannot download mongo db enterprise on my Windows 10 laptop. After I go to the link. I selected
Version: 4.2.0 (current release)
OS: Windows x64 x64
Package: nothing can select
Then, I click Download button and nothing happen.
I tried that on Chrome, Firefox, and IE, but no one works.


I have the same issue and try the same as previous users. Something that I noticed is that when the page of the given link loads it gives me a 404 error message.

Definitely something is happening with the server:

Hi @Daniel_19485,

There is some issue with the MongoDB Download Centre page at the moment. The concerned team is working on it and hopefully the issue would be resolved at the earliest.

In the meantime, you can download the Enterprise Server using this link.

Shubham Ranjan
Curriculum Support Engineer

1 Like

I cannot download the Enterprise version, I got: “An unexpected error occurred.” is the same message when I tried to download the Mongo Compass stable version.


I choose following options:

Hi @karla_21453,

The issue has been resolved and you should be able to download the binaries without any difficulty. Please try to download again. However, if you are still unable to download the binaries please let me know.

Shubham Ranjan
Curriculum Support Engineer