Not able to connect to compass

I have a problem connecting to compass, I have this error:
“An error occurred while loading navigation: ‘not master and slaveOk=false’: It is recommended to change your read preference in the connection dialog to Primary Preferred or Secondary Preferred or provide a replica set name for a full topology connection.”
Did anyone have the same problem? how to fix it plz?

As you will learn in other classes (like M103) this happens when you connect directly to a secondary host in a replica set, instead of connecting to the replica set and letting it connect you to the primary automatically.

This usually happens when you forget to specify the replica set name in the connection settings.

I’m having the same issue for both my Atlas Sandbox cluster and Class cluster. Tried changing ‘read preference’, but didn’t work.

Only the Sandbox cluster has a Replica Set Name set.

I have the same issue. So impossible for me to answer to the quiz comparaison operators:thinking:
Edit: i found an answer with mongo shell in terminal

Did you solve the problem?
I killed compass service on windows, then I tried to uninstall it.
I launched after Compass and it worked.
I hope that can help you finish the final exam :slight_smile:

Thanks Samia,
yes all is ok now. I made like you, i’ve reinstalled compass.
quiz and final exam are finished !