Not able to add shard1 in M103 Chapter 3 Lab: Deploy a Sharded Cluster

Hi all,
I’ve been having a lot of trouble with the Deploy a Sharded Cluster lab in M103 Chapter 3. I’m very new at all this, so I’m sure my thinking is wrong somewhere.
Below are the steps I tried for the lab (Deploy a sharded cluster):
After each step (surrounded by stars) I included the command I used. I can successfully pass the first test which is getting mongos to run but am unable to add a shard to pass the second test.

1. Edit config file:
sharding:
configDB: csrs/localhost:27004,localhost:27005,localhost:27006

2. Start the mongos server:
mongos -f mongos.conf

3. Connect to mongos:
mongo --port 26000 --username m103-admin --password m103-pass --authenticationDatabase admin

4. Add a shard (this step returns a syntax error as shown below)
sh.addShard(“shard1/localhost:27002”)

Any help would be greatly appreciated.
Thank you!

Your quotes look different.Use double quotes
Try to type instead of cut & paste

1 Like

Thank you, that fixed it! I really appreciate the help!

1 Like