No validation code after running "pytest -m connection"

My computer is Win10 and I have already installed the python3, so I created the virtual environment for MFlix. I did everything on Windows command Prompt.

The following is the version of Python and Pip.
‘’’
(mflix_venv) C:\Program Files\MongoDB\M220P\mflix-python>python --version
Python 3.8.3

(mflix_venv) C:\Program Files\MongoDB\M220P\mflix-python>pip --version
pip 21.1.3 from c:\program files\mongodb\m220p\mflix-python\mflix_venv\lib\site-packages\pip (python 3.8)
‘’’

I solved some problems and I did the following steps, but I didn’t pass the test.

  • Install rustup from https://rustup.rs/
  • install pipwin and then install pyzmp and pywinpty
    ‘’’
    pip install pipwin
    pipwin install pyzmq
    pipwin install pywinpty
    ‘’’

Then, I removed “pyzmq==18.1.0” in the requirements.txt and run
‘’‘pip install -r requirements.txt’’’

After that, I didn’t see any problem.

Notice that I install the pyzmq-22.1.0-cp38-cp38-win32.whl.

I can start MFlix, after setup the .ini file and also can see the movie webpage.
‘’’(mflix_venv) C:\Program Files\MongoDB\M220P\mflix-python>python run.py’’’

However, when I run the test, there are 39 deselected and cannot get the validation code for Connection
‘’’
(mflix_venv) C:\Program Files\MongoDB\M220P\mflix-python>pytest -m connection
============================= test session starts =============================
platform win32 – Python 3.8.3, pytest-3.3.0, py-1.8.0, pluggy-0.6.0
rootdir: C:\Program Files\MongoDB\M220P\mflix-python, inifile: pytest.ini
plugins: flask-0.11.0
collected 43 items

tests\test_db_connection.py … [100%]

============================= 39 tests deselected =============================
=================== 4 passed, 39 deselected in 5.54 seconds ===================
‘’’

There is no error, but also no any validation code for the “Ticket: Connection”.

Thanks,

Johnny