No response for Match lab, anyone else?

I am not getting an error code, but I can connect to the cluster, load the validateLab1 JS file and run the pipeline function but I get no response in my command prompt.

Anyone getting a similar issue?

Post a screenshot of the issue.

Sure, there is no error message.

I get the same empty response in a normal CMD

And it doesnt timeout

Check this link.It may help

Problem with Lab $match : validateLab1(pipeline)

Yea that doesn’t solve the issue sadly. I am following the instructions.

Connect to cluster. :white_check_mark:
Load validateLab1 file and receive TRUE in console. :white_check_mark:
Run the validateLab1(pipeline) :white_check_mark:

It just pauses. No response or error in the console. :upside_down_face:

Ahh I am getting new errors. Will keep you updated, may have fixed something

Solved It thank you for the help

1 Like

I’m also facing the same issue, No response after running validateLab1(pipeline). I also tried to run the aggregate function based on the query condition mentioned and without JS function to see if there are documents matching the query condition, No results returned. Please assist me on how to proceed.

Can be any of the following:

  1. connected to wrong cluster
  2. using the wrong database
  3. using the wrong collection
  4. collection has been altered and does not contain the original matching documents
  5. pipeline is wrong
1 Like

Hi @Laks,

Make sure that you have downloaded and saved the handout chapter1.zip in the m121 directory.
Then try to connect to the mongo shell using the given connection string from within the m121 directory.

If you are still facing any issues, please share the screenshots of the steps that you are following to validate the lab.

Kind Regards,
Sonali

How could you solve it? I still have the same problem

Show us the screenshot
What error are you getting?
Does this query give results?
db.movies.aggregate(pipeline).itcount()

1 Like

I could solved it now. I was doing a sintax error. Thank you so much for helping :slight_smile: