Hello, I am getting the above error after setting up the free tier Mongo Atlas cluster and trying to use the db for my node js app. I am really stuck. The app is complete and I am in the process of deploying to heroku. Any help is highly appreciated. Thanks

Have you setup the network security of your cluster to give access from your application server?


Hi, thank you for you’re reply. First I whitelisted my ip. Didn’t work. Then I allowed access from anywhere( still same error. Is this what you are referring to or is there something else I should be doing?

What do you get when trying to go at ?

1 Like

Hey @steevej, thanks again. This was weird one. Really not sure what caused it. After googling for three days and getting nothing, I, out of nowhere, connected my laptop to my phone’s cellular data and tada… it worked. No changes to my code or atlas config. I managed to get it working, pushed everything to heroku and my app is actually live. If you don’t mind, check it out @ Thanks again. BTW if I go to the url in your comment, it just times out. Don’t know why.


Because you wired network does not allow out traffic on the given port by firewall or VPN. That’s the purpose of the link, to test if outgoing traffic is allowed or not. That is why using cell’s hotspot it worked, it is not restricted.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.