MongoDB on MacOS


I got problems setting up mongodb on my Mac, I’ve tried to follow the instructions on this site: " ", but when I arrived at brew services list (I didn’t stop it and restarted it several times) I got this:

brew services list

Name              Status  User       Plist
mongodb-community error   name/Users/name/Library/LaunchAgents/homebrew.mxcl.mongodb-` 

When I tried brew link mongodb I got this:

brew link mongodb-community
Linking /usr/local/Cellar/mongodb-community/4.4.3... 
Error: Could not symlink bin/mongo
Target /usr/local/bin/mongo
already exists. You may want to remove it:
  rm '/usr/local/bin/mongo'

To force the link and overwrite all conflicting files:
  brew link --overwrite mongodb-community

To list all files that would be deleted:
  brew link --overwrite --dry-run mongodb-community

I got the newest Mac OS version and I’m wondering what could’ve gone wrong, I was planning on installing the daemon and the shell.

I’d be very thankful for any recommendations/ hints



There is not much to add:

And the solution

after checking which files will be affected

1 Like

Thank you for your reply, unfortunately, the error persists, I still can’t start it and the status remains the same. I tried updating homebrew, uninstalling everything, reinstalling it with several youtube tutorials on how to do so, and reinstall it as they said on the website. Follow the instructions you and the terminal gave me etc. but nothing seems to have any effect

I also tried to manually remove all config files, log files etc. after I uninstalled it and I reinstalled homebrew, but nothing seems to change the outcome

Are you running brew as an administrator with the appropriate privileges?

You might want to use sudo brew rather than brew alone.

1 Like

Thank you, I got the latest Mac OS version, which means that running home brew as root is no longer supported. I think it might have something to do with the latest OS X version, I found several forum posts about this issue with no apparent solution. I think for now I will resort to using Virtual Box and Ubuntu until I find a better solution.

You may try asking on MongoDB Developer Community Forums. I am sure someone over there is more acquainted with MacOS than I am.


Hey @Marvin_Jung,

If you haven’t already created a post in our community forum then please create it under developer-tools category and someone form the team would be able to help you out.