MongoDB download for MAC

The video shows to use 3.4.6. But I cannot find 3.4.6 for my MAC. …it is 4.0.3 there. Is it OK ?

Yes, I’m using the latest client (on an older IMac here)

> mongo --version

MongoDB shell version v4.1.4

git version: 2f4b5918497b09a226a3ec5dcff930edd52ea1e9

allocator: system

modules: enterprise

build environment:

distarch: x86_64

target_arch: x86_64

Just make sure you grab the version that has SSL, there is one that is labeled “No SSL Support”

1 Like

@Mike_67094 -

Another Mac User here. I downloaded v4.1.4 as well. Did you copy over the files in /bin to another location on your mac? If so, where?

Hi @Elizabeth_23934 I just put it into a new folder (one for community) and (one for enterprise) Then in my .bash_profile I set

export MONGODB_COMMUNITY=/path to community edition/bin

export MONGODB_ENTERPRISE=/path to enterprise edition/bin

then in my main $PATH I just set it to the enterprise

For Compass I just downloaded it into a new folder as well and launched it from the applications folder.


1 Like

Hi @Mike_67094,

I was premature in asking this question, my apologies. Watched the install for MacOS and got it working.

Thanks again!


No Worries have fun!

The MongoDB 4.1.X versions are the ones from the development team. Those versions are targeted to be released many months down the road, and a lot of the features are not completed and/or tested.

Please use a MongoDB 4.0.X version!
…unless you like to live dangerously.


@danielcoupal Thanks for the heads up, I thought as much based on the “Development” tag, the challenge was that the 4.0.x version listed (current release) for MacOSX indicates it doesn’t have SSL support that the instructor indicated was needed for the class. This is based on the info in the drop-downs at the time at this link:

For example the 4.0.4 enterprise (current release) has “OS (macOS 64-bit, without SSL support x64)” as the only option listed for that version, whereas the 4.1.x appears to be the only version where there is a “macOS x64” option listed (minus the “without SSL support”) text.

But If I navigate to the “Current Releases & Packages” link to the right:

I see a 4.0.4 release now that doesn’t appear to have the “without SSL Support x64” text…

I think part of the confusion for me was that the class directed us to use the download page/drop downs but introduces the SSL support question for MacOSX, so I opted for a newer build even if it was development at least for class purposes anyway.



As a mac user I simply used homebrew with the following command, so it takes care of paths and executables:

brew install mongodb

Worked out of the box then.



I am also using Mac 4.1.6. I am getting connection failed when I tried to connect $ mongo.
Can anyone tell me the problem?

Hi Gayathri_10773,

Thanks for reaching out. Before connecting to mongo, make sure your mongo daemon is running. To start:

  $ mongod

Then, start your mongo shell:

 $ mongo

And As I can see you are using 4.1.6 version which is not current release, please download and install **Mongo 4.0.5 Current Release" from