MongoDB Compass doesn't run on my MacBook Pro

Downloaded Compass (stable 1.18.0), and started it, but it shows this graphic on the intro screen on my MacBook Pro (v10.11.4).

Tried the Beta and Community version also to see if it worked, but it doesn’t.

Any help would be appreciated.


Is your memory/internet speed fine?

Schema view in 1.16 stable version

Hi @Hsieh_78666,

It seems like an issue with a display. Can you please try to restart your system and then connect to the Compass.

This version should also work fine.

Let me know, if restarting the system doesn’t help.


Shutdown, started my laptop, downloaded fresh copy. Still see the strange image.

Internet is fine. How much memory does it need?

Found Compass Version 1.5.1 (1.5.1). The intro screen works.
Where can I find archived versions of Compass?

Hi @Hsieh_78666,

This version of Compass is too old and there is a possibility of running into some other error.

Please upgrade your Macbook version to minimum 10.12 (Sierra) as MacBook 10.11 version is not supported with Compass 1.18.

I would also recommend you to proceed further with your course as the due date for Chapter 1 is approaching. Moreover, you can complete most of the labs using Mongo Shell.

I hope it helps!!

Let me know, if you face any issues.


After updating my computer to Mojave, Compass 1.18 now works. However, I have other apps that won’t run on Mojave, like vagrant, unfortunately.

Thanks for the help !

Hi @Hsieh_78666,

Great to hear that Compass works now!!

Vagrant should work fine on Mac Mojave. However, if you are facing any issues with vagrant, please feel free to post on our forums for course M103: Basic Cluster Administration.