MongoDB Compass does not start in Ubuntu 18.10

I am using Ubuntu 18.10. Have installed Compass but it refuses to run. Don’t know why.

Ditto, running on Kali Linux, another Debian-like. Don’t know why Compass won’t run, it’s just stuck on the “Loading” screen. I haven’t managed to get it working :expressionless:

Are you running Ubuntu in a VM, or on bare metal? If it’s a VM, which platform are you using, on which host OS?

I was running Kali, through VMWare Fusion on MacOS.

Kali is specialized as a security tool, I think. Must have some setting that is not compatible with MongoDB Compass. You can ask Kali forum why Compass won’t work :slight_smile:

I suggest using vanilla Debian Stretch. I was stuck with Debian for a very long time, just because it has “Apt Store” built into it. – I’m a conservative when it comes to technology – or just lazy. Debian satisfies my requirement both as a desktop and or as a server. I’m no expert in Debian but I managed to get around everything, so far, using it’s very good and helpful forum. (haha - I’m proud to advertise Debian.)

MacOS is a very good OS indeed coupled with a very good hardware. You can’t go wrong with installing Compass directly.

Lately my desktop is getting ‘fat’ with all the new tech I installed out of “Apt Store”. It now means my Debian is getting left behind. Just because newer techs are being developed very very fast. I’m in uncharted territory. If something go wrong, it’s gonna be a mess. It was late that I setup Virtual Box for testing servers. So I have a server I can move around and not worry about major settings. I once got interested in Docker for a moving server - but it’s a little heavy on the learning curve. I got lucky with Virtual Box so I’m staying with Virtual Box, although I heard VM is much better.

Ubuntu is Debian based. And I’m a LITTLE envious of Ubuntu because its Apps are fresher than Debian. I need to tweak Debian stable if I wanted newer versions of Apps. In this case, I’m thankful MongoDB has some instructions for installing it’s latest stable App into Debian. Also, I have from time to time visited Ubuntu forum for troubleshooting my Debian desktop and I almost always found a solution from Ubuntu forum.

Am running Ubuntu on bare metal.

Ehhh, it’s mostly a normal Debian. What sets it apart is that it has lots of security software pre-installed. I’ll give’m a poke on the forums though; see what they can tell me.

Interesting! Instead of launching Compass through the Gnome searchbar, I fired up “mongodb-compass-community” from a terminal/bash prompt. This time it does start up properly, but gets stuck on a license popup.

Aaaand it’s stuck again. Restarted and it’s stuck on loading again. Restarted and I managed to get past the license and intro, but now it’s stuck again on the privacy popup. Blegh, I hope it works a lot better for other Linux users.

Meh… I switched my Kali from Gnome to XFCE4, thinking that perhaps Compass was fighting too much with the window manager. But no dice… It booted up just fine and then hangs again, completely unresponsive.

Starting with “DEBUG=* mongodb-compass-community” provides absolutely no useful hints about what is the blocking issue.

Well, that rules out the theory that it’s caused by specific virtualization setups.

Yeah keep on inventing. Time will pass and the course schedule will be over.

I could be reading your post wrong, but to me your message sounds rather hostile. I’m only trying to help you troubleshoot your issues, as a fellow student…

Sorry, if my reply hurted you. What I tried to mean is why people like you and me should be trying to figure out the problem? The tutor and the supporting staffs are very well aware of the problem, and they should mention a way out. It’s going in such a manner as if they have no knowledge of this problem. Should we keep on trying ourselves and the time will pass by and we will be left behind. I have left the course out of disgust. It’s must be a bud in the application. Could even submit the assignment.

1 Like

Hello, have u solved that problem? On Ubuntu forums is reported that for whatever reason Compass versions from 14 up dont work on Ubuntu 18 while compass 14 and previous go perfectly. The problem is that Mongo server doesnt allow to download versions before 15…