Mongodb Compass and Shell For Chromebook

Hi everybody. Anyone know how to install Compass and Shell on chromebook?


Obviously the first question is going to be: which OS are you running on it?

The second would be: is it on an ARM processor?

And the actual first question would be: have you tried searching for yourself? And if so, what did you find and why did it not work for you?

MongoU is a place to learn, so we’d definitely encourage you to try and figure things out for yourself first.

Alternatively, you could of course fire up a free tier VM on AWS, Azura or another cloud provider of your choice and run the tools on there.

I am on google Chrome OS. Its hp chromebook and I was looking up and it looks like its not on ARM processor.

None of the platforms in the download is for Chromebook. I tried few ubuntu and linux but it said not an executable for chromebook.

I also logged in the cloud version. But when connecting to the clusters using the shell, it again asked me to download the shell(which I cant find for chromebook).

I need to get it done before the chapter 2 expires on tuesday :frowning:


Well, if you’re in a big hurry I suggest you spin up a free-tier VM and run the shell from there. If you have no other way of running a Linux/Windows, then that’s it…

Thanks. What are the steps to get the free-tier VM access. I just created cluster/sandbox, is it at the same place of Shell is a different cloud?

Oh no, no… I’m talking about AWS (Amazon) or Azure (Microsoft). Both are cloud providers that allow you to run virtual machines on their environments and up to a certain limit this can be done for free. So you’d need to make an account with them and setup a VM through the relevant control panels. It can be quite confusing though, because there are so many options in there.

It’s outside the scope of these forums to help set up VMs on a cloud provider. There are youtube videos and other articles available that show how to do it.

Okay I got the windows machine and installed the shell. Now when I try to connect to my sandbox via my command prompt. Its throwing below error. Any help with that please

C:\Users\jshfl>mongo --nodb
MongoDB shell version v4.0.4
Welcome to the MongoDB shell.
For interactive help, type “help”.
For more comprehensive documentation, see
Questions? Try the support group


C:\Users\jshfl>mongo “mongodb://,,” --ssl --authenticationDatabase admin --username m001-student --password m001-mongodb-basics
MongoDB shell version v4.0.4
connecting to: mongodb://,,
2018-11-10T16:57:50.446-0500 I NETWORK [js] Starting new replica set monitor for JunaidCluster-shard-0/,,
2018-11-10T16:58:00.775-0500 W NETWORK [js] Unable to reach primary for set JunaidCluster-shard-0
2018-11-10T16:58:00.775-0500 I NETWORK [js] Cannot reach any nodes for set JunaidCluster-shard-0. Please check network connectivity and the status of the set. This has happened for 1 checks in a row.
2018-11-10T16:58:16.285-0500 W NETWORK [js] Unable to reach primary for set JunaidCluster-shard-0
2018-11-10T16:58:16.285-0500 I NETWORK [js] Cannot reach any nodes for set JunaidCluster-shard-0. Please check network connectivity and the status of the set. This has happened for 2 checks in a row.
2018-11-10T16:58:16.287-0500 E QUERY [js] Error: connect failed to replica set JunaidCluster-shard-0/,, :
exception: connect failed

I can connect to your cluster just fine.

Tokijin-4:~ tess$ nslookup

Non-authoritative answer: canonical name = canonical name =

tess$ nc 27017

tess$ openssl s_client -connect </dev/null >/tmp/bla
depth=2 C = US, O = DigiCert Inc, OU =, CN = DigiCert Global Root CA
verify return:1
depth=1 C = US, O = DigiCert Inc, CN = DigiCert SHA2 Secure Server CA
verify return:1
depth=0 C = US, ST = New York, L = New York, O = "MongoDB, Inc.", OU = Cloud SRE, CN = *
verify return:1

Both netcat and openssl s_client connect without problems. So there’s something on your end blocking you from connecting to the box.

If you’re on Windows, you can try the following tests in Powershell:


Test-NetConnection -ComputerName -Port 27017

If that connection fails, then something in your network blocks you from accessing your cluster.

As a side note: if you want to follow other courses on MongoU, the Chromebook is not going to be enough. Most other courses require you to run a virtual machine on your system, which requires decent hardware and additional software (VirtualBox and Vagrant).

got pass this hurdle as well. It was the firewall. Now I am able to work in the shell fine. Thankyou so much for your help. Definitely, no more chromebook now :stuck_out_tongue:

1 Like