MongoDB Charts - Add-user command error: An error occurred authenticating

I am trying to install MongoDB charts on my local (MacBook)

>cd mongodb-charts
>docker swarm init
>docker pull
>docker run --rm charts-cli test-connection 'mongodb://username:password@hostname:27017/DATABASE?replicaSet=rd0&authSource=admin'

MongoDB connection URI successfully verified.

>echo "mongodb://username:password@hostname:27017/DATABASE?replicaSet=rd0&authSource=admin" | docker secret create charts-mongodb-uri -

>docker stack deploy -c charts-docker-swarm-19.12.1.yml mongodb-charts
        Creating network mongodb-charts_backend
        Creating service mongodb-charts_charts
>docker service ls

ID                  NAME                    MODE                REPLICAS            IMAGE                            PORTS
44nfwa84c9ug        mongodb-charts_charts   replicated          1/1          *:80->80/tcp, *:443->443/tcp

>docker exec -it $(docker container ls --filter name=_charts -q) charts-cli add-user --first-name "Admin" --last-name "Admin" --email "" --password "admin1234" --role "UserAdmin"

add-user command error: An error occurred authenticating: request to http://localhost:8080/api/admin/v3.0/auth/providers/local-userpass/login failed, reason: connect ECONNREFUSED


docker service logs 44nfwa84c9ug
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: parsedArgs
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: installDir (’/mongodb-charts’)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: log
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: salt
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: productNameAndVersion ({ productName: ‘MongoDB Charts Frontend’, version: ‘1.9.1’ })
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: gitHash (‘1a46f17f’)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: supportWidgetAndMetrics (‘off’)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: tileServer (undefined)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: tileAttributionMessage (undefined)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: rawFeatureFlags (undefined)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: encryptionKeyPath
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: featureFlags ({})
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: tokens
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchMigrationsLog ({ completedStitchMigrations: [ ‘stitch-1332’, ‘stitch-1897’, ‘stitch-2041’, ‘migrateStitchProductFlag’, ‘stitch-2041-local’, ‘stitch-2046-local’, ‘stitch-2055’, ‘multiregion’, ‘dropStitchLogLogIndexStarted’ ] })
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: chartsMongoDBUri
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchConfigTemplate
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: lastAppJson ({ stitchAppId: ‘5eab6b1a0ce2af366132fc26’, stitchClientAppId: ‘mongodb-charts-jhyce’, stitchGroupId: ‘5eab6b190ce2af366132fc14’, gitHash: ‘1a46f17f’, tenantId: ‘1f7ac5f8-7f37-4e8d-8796-5b3d70e498e8’, featureFlags: {}, tileAttributionMessage: ‘’, appName: ‘MongoDB Charts Frontend’, appVersion: ‘1.9.1’, deployDate: ‘Fri, 15 May 2020 16:42:36 GMT’, target: ‘on-prem’, telemetry: { enabled: false, stitch: { appId: ‘datawarehouseprod-compass-nqnxw’ }, intercom: { appId: ‘w5bmt65h’, enabled: true, panelEnabled: true } } })
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: existingInstallation (true)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: tenantId (‘1f7ac5f8-7f37-4e8d-8796-5b3d70e498e8’)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: libMongoIsInPath (true)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: mongoDBReachable (true)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchMigrationsExecuted (‘not required’)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: minimumVersionRequirement (true)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchConfig
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchConfigWritten (true)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchChildProcess
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: indexesCreated (true)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchServerRunning (true)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: stitchAdminCreated (false)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: lastKnownVersion (‘1.9.1’)
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: existingClientAppIds ()
mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_check_mark: migrationsExecuted ({})

mongodb-charts_charts.1.lydkoixon6e7@docker-desktop | :heavy_multiplication_x: stitchUnconfigured failure: app “mongodb-charts-jhyce” not found. To reconfigure Charts with a fresh database, delete the mongodb-charts_keys volume and deploy again.

We are using MongoDB Version 4.0.5 community edition
How to fix this? @tomhollander any suggestion?

Hi @alak_patel -

The last line in the log shows what’s going on. Basically - the mongodb-charts_keys volume contains some files which expect certain data to exist in the database, but it’s not there. I’m not sure how you got into that state, but you can start fresh by deleting that volume using docker volume rm mongodb-charts_keys.

Let me know if this works.

I deleted mongodb-charts_keys and also deleted app, auth, metadata and config. Then redeployed.
Now I getting following error :slightly_frowning_face:

➜ mongodb-charts >  docker exec -it $(docker container ls --filter name=mongodb-charts_chart -q) charts-cli add-user --first-name "admin" --last-name "admin" --email "" --password "adminadmin" --role "UserAdmin"

➜ add-user command error: clientAppId not found. No Charts apps configured to add user to.

Service logs

➜ mongodb-charts docker service logs yzcg7xb5jqep
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: parsedArgs
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: installDir (’/mongodb-charts’)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: log
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: salt
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: productNameAndVersion ({ productName: ‘MongoDB Charts Frontend’, version: ‘1.9.1’ })
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: gitHash (‘1a46f17f’)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: supportWidgetAndMetrics (‘off’)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: tileServer (undefined)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: tileAttributionMessage (undefined)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: rawFeatureFlags (undefined)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: stitchMigrationsLog ({ completedStitchMigrations: })
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: featureFlags ({})
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: lastAppJson ({})
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: existingInstallation (false)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: tenantId (‘52ca28a0-841d-4207-b14f-bcf27ae1307f’)
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: chartsMongoDBUri
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: tokens
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: encryptionKeyPath
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: stitchConfigTemplate
mongodb-charts_charts.1.xsmlaf4b71n8@moby | :heavy_check_mark: libMongoIsInPath (true)

I am using

MacOS 10.13.6 High Sierra
Docker Version : 17.09.1-ce
MongpDB Version: 4.0.5 Community
MongoDB Charts : 19.12.1

@tomhollander How do I fix this error ?

@alak_patel - that log file does not look complete. Possibly you ran the add-user command before the services had all started. Please try again after waiting a bit longer, or if all else fails delete the stack and try again.

After deleting auth, app, config and metadata databases I ran following commands:

docker stack rm mongodb-charts
docker secret rm charts-mongodb-uri

Removing service mongodb-charts_charts
Removing network mongodb-charts_backend

docker volume rm mongodb-charts_keys


docker swarm leave --force

Node left the swarm.

docker swarm init

Swarm initialized: current node (ves6vggzkjgqg0d3b5ctdbpth) is now a manager.

To add a worker to this swarm, run the following command:

docker swarm join --token SWMTKN-1-1q6w99q3ydmhvvo5qpbi0vn9lo8nkc0izisobutq5nzw1f4nov-5xlxse8y9eg0t7bvgbbx4rrbz

To add a manager to this swarm, run ‘docker swarm join-token manager’ and follow the instructions.

docker pull

19.12.1: Pulling from mongodb/charts
f7e2b70d04ae: Already exists
08dd01e3f3ac: Already exists
d9ef3a1eb792: Already exists
4581df1af3c1: Already exists
d8fcb2ad31d7: Already exists
fd691f0ac82b: Already exists
24f9651c9353: Already exists
2e5fadc35a21: Already exists
f608968bc4d5: Already exists
06ee49454ba1: Already exists
41d2ff67bea6: Already exists
f5e63860bf14: Already exists
5650d9c5fe37: Already exists
dd45ce71d88d: Already exists
892241cbafcd: Already exists
bb13ccab3410: Already exists
eb7cec6a6d6e: Already exists
2515f3cd3dc7: Already exists
36f48ca24f54: Already exists
Digest: sha256:395c819f9b0faa05f80180eb3725a2539d69cd79a1dbeb8390b7b2e2922f6b54
Status: Image is up to date for

docker run --rm charts-cli test-connection “mongodb://username:password@host1:27017,host2:27017,host3:27017/DB_NAME?replicaSet=rd0&readPreference=secondary&authSource=admin”

MongoDB connection URI successfully verified.

Before starting Charts, please create a Docker Secret containing this connection URI using the following command:
echo "mongodb://username:password@host1:27017,host2:27017,host3:27017/DB_NAME?replicaSet=rd0&readPreference=secondary&authSource=admin" | docker secret create charts-mongodb-uri -

echo " mongodb://username:password@host1:27017,host2:27017,host3:27017/DB_NAME?replicaSet=rd0&readPreference=secondary&authSource=admin " | docker secret create charts-mongodb-uri -

docker stack deploy -c charts-docker-swarm-19.12.1.yml mongodb-charts

docker service ls

m5fggs1vludg mongodb-charts_charts replicated 1/1 :80->80/tcp,:443->443/tcp

docker service logs m5fggs1vludg

mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: parsedArgs
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: installDir (’/mongodb-charts’)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: log
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: salt
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: productNameAndVersion ({ productName: ‘MongoDB Charts Frontend’, version: ‘1.9.1’ })
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: gitHash (‘1a46f17f’)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: supportWidgetAndMetrics (‘off’)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: tileServer (undefined)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: tileAttributionMessage (undefined)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: rawFeatureFlags (undefined)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: encryptionKeyPath
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: featureFlags ({})
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: lastAppJson ({})
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: existingInstallation (false)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: tenantId (‘ce63a26f-eb0c-4d5c-9313-a396a8bf0214’)
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: chartsMongoDBUri
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: tokens
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: stitchMigrationsLog ({ completedStitchMigrations: [ ‘stitch-1332’, ‘stitch-1897’, ‘stitch-2041’, ‘migrateStitchProductFlag’, ‘stitch-2041-local’, ‘stitch-2046-local’, ‘stitch-2055’, ‘multiregion’, ‘dropStitchLogLogIndexStarted’ ] })
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: stitchConfigTemplate
mongodb-charts_charts.1.7jv37pezwjv1@moby | :heavy_check_mark: libMongoIsInPath (true)

docker exec -it $(docker container ls --filter name=mongodb-charts_chart -q) charts-cli add-user --first-name “admin” --last-name “admin” --email “” --password “adminadmin” --role “UserAdmin”

add-user command error: clientAppId not found. No Charts apps configured to add user to.

@tomhollander I see that service is started, but still getting error on add-user.

The service is running, but the startup process is not complete which explains why add-user isn’t working. There should be several more lines written to the log, finishing with:

✔ supervisorStarted (true)

The line expected immediately after ✔ libMongoIsInPath (true) is ✔ mongoDBReachable (true) which makes me think it’s having some trouble with the DB connection, despite the fact that it validated. Can you look at the file /mongodb-charts/logs/charts-cli.log within the container and see if that offers any clues? Feel free to email me at tom.hollander at if you don’t want to share your logs with the world.


@tomhollander, I don’t see any logs file created. There is no /mongodb-charts/logs/charts-cli.log

I even tried creating directory /mongodb-charts/logs/ manually and redeployed.
But don’t see any files within /mongodb-charts/logs/

This is the yml file I am using

version: “3.3”

hostname: charts
# host:container port mapping. If you want MongoDB Charts to be
# reachable on a different port on the docker host, change this
# to :80, e.g. 8888:80.
- 80:80
- 443:443
- keys:/mongodb-charts/volumes/keys
- logs:/mongodb-charts/volumes/logs
- db-certs:/mongodb-charts/volumes/db-certs
- web-certs:/mongodb-charts/volumes/web-certs
# The presence of following 2 environment variables will enable HTTPS on Charts server.
# All HTTP requests will be redirected to HTTPS as well.
# To enable HTTPS, upload your certificate and key file to the web-certs volume,
# uncomment the following lines and replace with the names of your certificate and key file.

  # This environment variable controls the built-in support widget and
  # metrics collection in MongoDB Charts. To disable both, set the value
  # to "off". The default is "on".
  # Directory where you can upload SSL certificates (.pem format) which
  # should be considered trusted self-signed or root certificates when
  # Charts is accessing MongoDB servers with ?ssl=true
  SSL_CERT_DIR: /mongodb-charts/volumes/db-certs
  - backend
  - charts-mongodb-uri



external: true

Is something wrong here?

Your Swarm file looks fine to me.

Just to double check the log file (which should be there): can you try running the following from outside the container, while the container is running?

docker exec -it $(docker container ls --filter name=_charts -q) cat /mongodb-charts/logs/charts-cli.log



After deployment service was up and running. After service was up, the log file was just stuck at

waiting for MongoDB, attempt #1 to connect to MongoDB

I thought it might take some time. So I checked every 1 hour. But still same status. Here is what I. see when I run the. command that you sent:

> docker exec -it $(docker container ls --filter name=_charts -q) cat /mongodb-charts/logs/charts-cli.log                                                                   
> 2020-07-15T23:18:07.028+00:00 INFO  called charts-cli startup with arguments {"_":["startup"],"debug":false,"help":false,"version":false,"with-test-facilities":false,"withTestFacilities":false,"d":"/mongodb-charts","directory":"/mongodb-charts","$0":"mongodb-charts/bin/charts-cli.js"} 
> 2020-07-15T23:18:07.033+00:00 INFO  parsedArgs task success  
> 2020-07-15T23:18:07.035+00:00 INFO  installDir task success ('/mongodb-charts') 
> 2020-07-15T23:18:07.035+00:00 INFO  log task success  
> 2020-07-15T23:18:07.036+00:00 INFO  salt task success  
> 2020-07-15T23:18:07.043+00:00 INFO  productNameAndVersion task success ({ productName: 'MongoDB Charts Frontend', version: '1.9.1' }) 
> 2020-07-15T23:18:07.043+00:00 INFO  gitHash task success ('1a46f17f') 
> 2020-07-15T23:18:07.043+00:00 INFO  supportWidgetAndMetrics task success ('off') 
> 2020-07-15T23:18:07.043+00:00 INFO  tileServer task success (undefined) 
> 2020-07-15T23:18:07.043+00:00 INFO  tileAttributionMessage task success (undefined) 
> 2020-07-15T23:18:07.043+00:00 INFO  rawFeatureFlags task success (undefined) 
> 2020-07-15T23:18:07.049+00:00 INFO  stitchMigrationsLog task success ({ completedStitchMigrations: [] }) 
> 2020-07-15T23:18:07.050+00:00 INFO  featureFlags task success ({}) 
> 2020-07-15T23:18:07.059+00:00 INFO  lastAppJson task success ({}) 
> 2020-07-15T23:18:07.059+00:00 INFO  existingInstallation task success (false) 
> 2020-07-15T23:18:07.060+00:00 INFO  tenantId task success ('61e0ad7f-1aed-4f3d-b4a6-a183921a84c8') 
> 2020-07-15T23:18:07.062+00:00 INFO  chartsMongoDBUri task success  
> 2020-07-15T23:18:07.064+00:00 INFO  tokens task success  
> 2020-07-15T23:18:07.064+00:00 INFO  encryptionKeyPath task success  
> 2020-07-15T23:18:07.064+00:00 INFO  stitchConfigTemplate task success  
> 2020-07-15T23:18:07.066+00:00 INFO  libMongoIsInPath task success (true) 
> 2020-07-15T23:18:07.165+00:00 INFO  waiting for MongoDB, attempt #1 to connect to MongoDB at mongodb://username:*********@host1:27017,host2:27017,host3:27017/DB_NAME?replicaSet=rd0&readPreference=secondary&authSource=admin.

Thanks - at least we’re narrowing down the source of the problem. Basically it looks like it’s hanging when attempting to connect to the database. I’ve never seen this before so unfortunately I don’t have any great ideas on the cause or the solution. The code that’s hanging is basically just connecting to the DB and running isMaster, after which it should immediately log a success or failure message. If it fails, it will back off and try again a number of times, but there should still be multiple log events written.

All I can really suggest is to try a simpler database configuration, e.g. a single node DB instead of a replica set, just to see if you can get it working. Once you have something working, maybe you can gradually add more things and figure out the cause. That said, connecting to a replica set normally works, and the fact that your test-connection script succeeded implies it’s set up fine. But I think you’ve reached a point where more exploratory options are needed.


@tomhollander, thanks a lot for your help I deleted app, auth, metadata and config databases. Then tried with the simplest connection URI. After 7 attempts it finally connected to Stitch and its working now.


➜ mongodb-charts docker exec -it $(docker container ls --filter name=_charts -q) cat /mongodb-charts/logs/charts-cli.log

2020-07-22T15:44:26.708+00:00 INFO  called charts-cli startup with arguments {"_":["startup"],"debug":false,"help":false,"version":false,"with-test-facilities":false,"withTestFacilities":false,"d":"/mongodb-charts","directory":"/mongodb-charts","$0":"mongodb-charts/bin/charts-cli.js"} 
2020-07-22T15:44:26.712+00:00 INFO  parsedArgs task success  
2020-07-22T15:44:26.714+00:00 INFO  installDir task success ('/mongodb-charts') 
2020-07-22T15:44:26.714+00:00 INFO  log task success  
2020-07-22T15:44:26.714+00:00 INFO  salt task success  
2020-07-22T15:44:26.715+00:00 INFO  productNameAndVersion task success ({ productName: 'MongoDB Charts Frontend', version: '1.9.1' }) 
2020-07-22T15:44:26.715+00:00 INFO  gitHash task success ('1a46f17f') 
2020-07-22T15:44:26.715+00:00 INFO  supportWidgetAndMetrics task success ('off') 
2020-07-22T15:44:26.715+00:00 INFO  tileServer task success (undefined) 
2020-07-22T15:44:26.716+00:00 INFO  tileAttributionMessage task success (undefined) 
2020-07-22T15:44:26.716+00:00 INFO  rawFeatureFlags task success (undefined) 
2020-07-22T15:44:26.719+00:00 INFO  stitchMigrationsLog task success ({ completedStitchMigrations: [] }) 
2020-07-22T15:44:26.719+00:00 INFO  featureFlags task success ({}) 
2020-07-22T15:44:26.725+00:00 INFO  lastAppJson task success ({}) 
2020-07-22T15:44:26.725+00:00 INFO  existingInstallation task success (false) 
2020-07-22T15:44:26.726+00:00 INFO  tenantId task success ('a47f2a2f-f3a6-4496-a413-036d9883b861') 
2020-07-22T15:44:26.727+00:00 INFO  chartsMongoDBUri task success  
2020-07-22T15:44:26.728+00:00 INFO  tokens task success  
2020-07-22T15:44:26.729+00:00 INFO  encryptionKeyPath task success  
2020-07-22T15:44:26.729+00:00 INFO  stitchConfigTemplate task success  
2020-07-22T15:44:26.730+00:00 INFO  libMongoIsInPath task success (true) 
2020-07-22T15:44:26.829+00:00 INFO  waiting for MongoDB, attempt #1 to connect to MongoDB at mongodb://user:*******@host:27017/DB?replicaSet=rd0&authSource=admin. 
2020-07-22T15:44:27.117+00:00 INFO  waiting for MongoDB, successfully connected to MongoDB at mongodb://user:*******@host:27017/DB?replicaSet=rd0&authSource=admin after 1 attempts. 
2020-07-22T15:44:27.119+00:00 INFO  mongoDBReachable task success (true) 
2020-07-22T15:44:27.124+00:00 INFO  stitchMigrationsExecuted task success ([ 'stitch-1332',  'stitch-1897',  'stitch-2041',  'migrateStitchProductFlag',  'stitch-2041-local',  'stitch-2046-local',  'stitch-2055',  'multiregion',  'dropStitchLogLogIndexStarted' ]) 
2020-07-22T15:44:27.373+00:00 INFO  minimumVersionRequirement task success (true) 
2020-07-22T15:44:27.376+00:00 INFO  stitchConfig task success  
2020-07-22T15:44:27.378+00:00 INFO  stitchConfigWritten task success (true) 
2020-07-22T15:44:27.385+00:00 INFO  stitchChildProcess task success  
2020-07-22T15:44:27.485+00:00 INFO  waiting for Stitch to start, attempt #1 to connect to Stitch server at http://localhost:8080. 
2020-07-22T15:44:27.490+00:00 WARN  waiting for Stitch to start, attempt #1 failed: connect ECONNREFUSED 
2020-07-22T15:44:27.590+00:00 INFO  waiting for Stitch to start, attempt #2 to connect to Stitch server at http://localhost:8080. 
2020-07-22T15:44:27.591+00:00 WARN  waiting for Stitch to start, attempt #2 failed: connect ECONNREFUSED 
2020-07-22T15:44:27.791+00:00 INFO  waiting for Stitch to start, attempt #3 to connect to Stitch server at http://localhost:8080. 
2020-07-22T15:44:27.792+00:00 WARN  waiting for Stitch to start, attempt #3 failed: connect ECONNREFUSED 
2020-07-22T15:44:27.976+00:00 INFO  indexesCreated task success (true) 
2020-07-22T15:44:28.095+00:00 INFO  waiting for Stitch to start, attempt #4 to connect to Stitch server at http://localhost:8080. 
2020-07-22T15:44:28.096+00:00 WARN  waiting for Stitch to start, attempt #4 failed: connect ECONNREFUSED 
2020-07-22T15:44:28.598+00:00 INFO  waiting for Stitch to start, attempt #5 to connect to Stitch server at http://localhost:8080. 
2020-07-22T15:44:28.599+00:00 WARN  waiting for Stitch to start, attempt #5 failed: connect ECONNREFUSED 
2020-07-22T15:44:29.399+00:00 INFO  waiting for Stitch to start, attempt #6 to connect to Stitch server at http://localhost:8080. 
2020-07-22T15:44:29.400+00:00 WARN  waiting for Stitch to start, attempt #6 failed: connect ECONNREFUSED 
2020-07-22T15:44:30.703+00:00 INFO  waiting for Stitch to start, attempt #7 to connect to Stitch server at http://localhost:8080. 
2020-07-22T15:44:31.383+00:00 INFO  waiting for Stitch to start, successfully connected to Stitch at http://localhost:8080 after 7 attempts. 
2020-07-22T15:44:31.383+00:00 INFO  stitchServerRunning task success (true) 

I will now try adding more details to connection URL.

Thank you for your time. Appreciate your help.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.