mongoDB Active: failed (Result: core-dump)

Hardware: Raspberry Pi 3B
OS: Ubuntu 20.04 LTS

Hey I need help. I am very desperated.

I want to run mongoDB on my Raspberry Pi 3B. I run it with Ubuntu 20.04.6 LTS and mongoDB version 4.4, as sooo many thread mention, that the minimum recuired processor architecture is not fulfilled by any Pi (so far)

When I want to start mongoDB I get this error

mongod.service - MongoDB Database Server
Loaded: loaded (/lib/systemd/system/mongod.service; enabled; vendor preset: enabled)
Active: failed (Result: core-dump) since Sat 2023-07-01 12:28:44 UTC; 9s ago
Docs: https://docs.mongodb.org/manual
Process: 49592 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=dumped, signal=ILL)
Main PID: 49592 (code=dumped, signal=ILL)

Jul 01 12:28:41 ubuntu systemd[1]: Started MongoDB Database Server.
Jul 01 12:28:44 ubuntu systemd[1]: mongod.service: Main process exited, code=dumped, status=4/ILL
Jul 01 12:28:44 ubuntu systemd[1]: mongod.service: Failed with result 'core-dump'.

I installed mongoDB exactly following instructions of this tutorial from mongodb.com (Install & Configure MongoDB on the Raspberry Pi | MongoDB) where the instructions absolutely pay attention of fulfilling all known requirements. I tried this official (?) tutorial, since all previous attempts produces the same error (the same I am still confronting with). But nothing helps …

As I mentioned before I had this issue all the time before. I have to fight it for almost a month (it is a private project and I have really not so much time for it after work). And because no solution on the web helped me, I reinstalled Ubuntu completely on my Pi and did it exactly with the commands of the tutorial I linked above. And it still does not work.

I really don’t know what is wrong … I don’t know, why it is such a big issue (there are soooo many other threads already open) but without any solution. I really like mongoDB and this Pi will be the first tiny version of a server I plan to be put into a NAS one time.

But if it will not work, no matter what I try, I have to use another database framework which is able to save documents even with an older cpu. I really don’t know why it got this limitations, so it is not backward compatible … I mean … isn’t it just saving and getting documents? :-/

It makes me so sad that mongoDB is not backward compatible but also that it seems that no one seems to know any solution. I really like mongoDB, but since there are errors with such a big impact in such an early phase of my project, I cannot imagine running mongoDB in my productive system …

Hi @chris080G,

In my personal capacity I have built MongoDB from source and published binaries on Github here. While I have not attempted to run the binaries on a Pi 3, you can give it a try and report back.

The Illegal instruction error you are hitting is well documented here and on StackOverflow. Search for the many threads of people hitting the same issue (I have included a random sampling).

The storage engine of MongoDB, WiredTiger, is driving the requirement for a microarchitecture that exceeds that of Raspberry Pi’s and this is not going to change anytime soon.

Feel free to raise an issue on the Github repo if there is an issue with the binaries or procedure to run them.

I hope this helps get you unstuck.