MongoDB 6.0.5 Compatibility Issue with Ryzen 5 5500U on Ubuntu

Hello MongoDB Community,

I have been experiencing an issue when trying to run MongoDB 6.0.5 on my Ubuntu system with an AMD Ryzen 5 5500U processor (x86_64 architecture). When attempting to start the MongoDB service, I receive an “Illegal Instruction” error (signal=ILL), and the service fails to start. I have tried multiple troubleshooting steps, such as reinstalling MongoDB, checking the configuration file, and ensuring my system is up to date, but the issue persists.

Here is the error log from my system:

 mongod.service - MongoDB Database Server
      Loaded: loaded (/lib/systemd/system/mongod.service; enabled; vendor preset: enabled)
      Active: failed (Result: core-dump) since Sun 2023-03-19 21:05:35 UTC; 7s ago
     Process: 1870 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=dumped, signal=ILL)
    Main PID: 1870 (code=dumped, signal=ILL)
         CPU: 5ms
mar 19 21:05:35 database systemd[1]: Started MongoDB Database Server.
mar 19 21:05:35 database systemd[1]: mongod.service: Main process exited, code=dumped, > status=4/ILL
mar 19 21:05:35 database systemd[1]: mongod.service: Failed with result 'core-dump'.

My system information is as follows:
Linux database 5.15.0-67-generic #74-Ubuntu SMP Wed Feb 22 14:14:39 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux.

I understand that MongoDB requires an AMD Bulldozer or later processor for x86_64 systems, and the Ryzen 5 5500U is based on the Zen 2 architecture, which should be compatible. However, I am still encountering issues.

I would appreciate any assistance or insights from the community on how to resolve this problem or any suggestions for further troubleshooting steps.

Thank you in advance for your help!

P.s.: Mongo doesn’t even generate a log file.

Hello :wave: @Psycrow_N_A,

Welcome to the MongoDB Community forums :sparkles:

Sorry, you experienced these crashes. To further understand the problem, could you share the following information:

  • The details of how you installed it, including the link to the downloaded binary and the installation process you followed?
  • Has this issue only occurred with version 6.0.5? Have you tested it with the another version of 6.0?
  • Does this problem also occur in other supported versions such as MongoDB 5.0, etc?
  • Is it running on a docker or virtual machine?



I’ll try to answer as much as i can to help me and others with same issues.

  1. I’m running via virtual machine on proxmox (created only for mongodb).
  2. I’ve installed using the official website instructions Install MongoDB Community Edition on Ubuntu — MongoDB Manual:
  • wget -qO - | sudo apt-key add -
  • echo “deb [ arch=amd64,arm64 ] MongoDB Repositories jammy/mongodb-org/6.0 multiverse” | sudo tee /etc/apt/sources.list.d/mongodb-org-6.0.list
  • sudo apt-get update
  • sudo apt-get install -y mongodb-org

It’s basically those steps. Later i’ve tried with 6.04 and a 5.0 version as well, none of them worked. Them i’ve tried the Turnkey LXC Container for Mongodb (it uses the 4.4.4 version) and it worked really well. But i’m sad because i was willing to use latest version since i’m developing a new app and making a virtual machine for the database only for that purpose.

Glad those infos can help!

Hello @Psycrow_N_A,

Upon looking I found that Proxmox VM, uses KVM64 as the default CPU, and KVM64 doesn’t support full AVX instruction. As a result, it is not compatible with binaries compiled for newer microarchitectures, such as MongoDB 5.0+.

This issue has also been reported by other members of the Proxmox community on forums and GitHub.

Since you are intending to use the latest MongoDB 6.0, your current options include:

  • Changing your VM’s CPU from KVM64 to the host CPU of your guest VM image.
  • Or, upgrading your VM or hosting solution to support newer microarchitecture with AVX (Advanced Vector Extensions) .


A post was split to a new topic: Facing Issue while installing MongoDB on RedHat