Mongod not working

Hi,
I installed mongodb on my mabook air m1 for learning mongodb, and everything went right i created database and did learned soo many things

but after 2 hours the mongod command showed a error and mongo command also didn’t worked
now i am not able to create a databse or mongo

harshchauhan@Harshs-MacBook-Air ~ % mongod
{"t":{"$date":"2021-06-20T16:13:09.506+05:30"},"s":"I",  "c":"CONTROL",  "id":23285,   "ctx":"main","msg":"Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'"}
{"t":{"$date":"2021-06-20T16:13:09.509+05:30"},"s":"W",  "c":"ASIO",     "id":22601,   "ctx":"main","msg":"No TransportLayer configured during NetworkInterface startup"}
{"t":{"$date":"2021-06-20T16:13:09.509+05:30"},"s":"I",  "c":"NETWORK",  "id":4648602, "ctx":"main","msg":"Implicit TCP FastOpen in use."}
{"t":{"$date":"2021-06-20T16:13:09.510+05:30"},"s":"I",  "c":"STORAGE",  "id":4615611, "ctx":"initandlisten","msg":"MongoDB starting","attr":{"pid":62625,"port":27017,"dbPath":"/data/db","architecture":"64-bit","host":"Harshs-MacBook-Air.local"}}
{"t":{"$date":"2021-06-20T16:13:09.511+05:30"},"s":"I",  "c":"CONTROL",  "id":23351,   "ctx":"initandlisten","msg":"{sysctlName} unavailable","attr":{"sysctlName":"machdep.cpu.extfeatures"}}
{"t":{"$date":"2021-06-20T16:13:09.511+05:30"},"s":"I",  "c":"CONTROL",  "id":23403,   "ctx":"initandlisten","msg":"Build Info","attr":{"buildInfo":{"version":"4.4.5","gitVersion":"ff5cb77101b052fa02da43b8538093486cf9b3f7","modules":[],"allocator":"system","environment":{"distarch":"x86_64","target_arch":"x86_64"}}}}
{"t":{"$date":"2021-06-20T16:13:09.511+05:30"},"s":"I",  "c":"CONTROL",  "id":51765,   "ctx":"initandlisten","msg":"Operating System","attr":{"os":{"name":"Mac OS X","version":"20.5.0"}}}
{"t":{"$date":"2021-06-20T16:13:09.511+05:30"},"s":"I",  "c":"CONTROL",  "id":21951,   "ctx":"initandlisten","msg":"Options set by command line","attr":{"options":{}}}
{"t":{"$date":"2021-06-20T16:13:09.512+05:30"},"s":"E",  "c":"NETWORK",  "id":23024,   "ctx":"initandlisten","msg":"Failed to unlink socket file","attr":{"path":"/tmp/mongodb-27017.sock","error":"Permission denied"}}
{"t":{"$date":"2021-06-20T16:13:09.512+05:30"},"s":"F",  "c":"-",        "id":23091,   "ctx":"initandlisten","msg":"Fatal assertion","attr":{"msgid":40486,"file":"src/mongo/transport/transport_layer_asio.cpp","line":919}}
{"t":{"$date":"2021-06-20T16:13:09.512+05:30"},"s":"F",  "c":"-",        "id":23092,   "ctx":"initandlisten","msg":"\n\n***aborting after fassert() failure\n\n"}

//Mongo Comm

harshchauhan@Harshs-MacBook-Air ~ % mongo

MongoDB shell version v4.4.5

connecting to: mongodb://127.0.0.1:27017/?compressors=disabled&gssapiServiceName=mongodb

Error: couldn't connect to server 127.0.0.1:27017, connection attempt failed: SocketException: Error connecting to 127.0.0.1:27017 :: caused by :: Connection refused :

connect@src/mongo/shell/mongo.js:374:17

@(connect):2:6

exception: connect failed

exiting with code 1 

//brew services list

harshchauhan@Harshs-MacBook-Air ~ %  brew services list
Name              Status  User         Plist
mongodb-community error   harshchauhan /Users/harshchauhan/Library/LaunchAgents/homebrew.mxcl.mongodb-community.plist
harshchauhan@Harshs-MacBook-Air ~ %

Hi @Harsh_Chauhan, welcome to the community.
Seems like this issue is already solved over here: Error: couldn't connect to server 127.0.0.1:27017

Hopefully, it will give you enough idea on what went wrong and how to resolve the same, but in case you have any doubts, please feel free to reach out to us.

Thanks and Regards.
Sourabh Bagrecha,
Curriculum Services Engineer