Mongod command with --dbpath data/db

When I run the mongod command with --dbpath data/db. It complains it does not exists? I thought this was default?

I just want to add to the above one when I run “vagrant@m103:~$ validate_lab_launch_mongod”
It complains run with dbpath option … so not sure what is happening

I have the same problem

That’s because the requirement is /data/db but you’ve done data/db. Hopefully you can see the difference because these are two different locations.


Thank you very much. I need to create this folder?.

The directory already exists but why is it complaining???

vagrant@m103:~ validate_lab_launch_mongod You need to specify db path /data/db. vagrant@m103:~ mkdir /data/db
mkdir: cannot create directory ‘/data/db’: File exists
vagrant@m103:~$ mkdir /data

Let’s see the full screenshots of:

  1. The mongod command
  2. ls -l /data
1 Like

That is resolved, I am getting this error

vagrant@m103:~$ validate_lab_launch_mongod
You need to bind the IP address to or localhost.

It is telling me to bing IP address which I don’t understand but the user is already created…
what is this issue?

Different problem = different topic. Suggest you create a new thread :slight_smile:
And search the forum before you do. This same issue has been discussed countless times.

Hi @munish_79545,

As @007_jb suggested, please search the forum. We already have a lot of thread dedicated to this issue.

You can also read about the --bind_ip option in our documentation.

Hope it helps!

Shubham Ranjan
Curriculum Support Engineer