Mongo --nodb command not found

I did everything Shannon did in the video but for some reason when I try to run mongo --db in terminal it returns mongo: command not found… Why could this be happening?

What message does it give you instead?

mongo: command not found

Hi @Keelana_33447,

You should try the following command if you want to prevent shell from connecting to any database instances :

mongo --nodb

Also, ensure that you have downloaded MongoDB Enterprise Server:

I hope it helps!!

Please let me know, if you have any questions.


I tried that too and it doesn’t work.

So I ended up figuring it out lol I tried it again from scratch. But I still don’t understand why in the video he updated the folder name the second time. I never got the ‘mongo: command not found’ error this time like it shows in the video. It ran perfectly the first time.

1 Like

That’s great. If I’m thinking of the same video, I think he had to updated it because he had a different version of Mongo that he wanted to use, but one was already installed previously.

hi, i also got same problem…after updating mac to mac catalina ,

…kindly help

I am not much familiar with macos but there are threads on updating PATH on macos like sudo nano /etc/paths etc
Please check
Also your PATH displays two mongodb’s?
Which is correct one?

Hi @Anuja_85051,

I have responded to you on this thread.

Shubham Ranjan
Curriculum Support Engineer

yes ,i am thankful for those threads available here,
but moving back to the bash shell/terminal from zsh is worked for me .
thank you