Mongo DB Realm Sync - Can't See the data on Atlas

I’m building an Android app using a Realm Sync Mongo DB library. The problem is that whenever I try to insert some data, I can see that data inside my local realm database file, however that data is not visible on the backend database on Mongo DB Atlas. I’ve already created a database. I’ve specified the schema for the model class like this:

{
  "properties": {
    "_id": {
      "bsonType": "objectId"
    },
    "id": {
      "bsonType": "objectId"
    },
    "name": {
      "bsonType": "string"
    },
    "online": {
      "bsonType": "boolean"
    },
    "wins": {
      "bsonType": "int"
    },
    "losses": {
      "bsonType": "int"
    },
    "draws": {
      "bsonType": "int"
    }
  },
  "title": "Users",
  "bsonType": "object",
  "required": [
    "_id",
    "id",
    "name"
  ]
}

This is the model class inside my project:

open class Users: RealmObject {
    @PrimaryKey var _id: ObjectId = ObjectId.create()
    var id: ObjectId = ObjectId.create()
    var name: String = ""
    var online: Boolean? = null
    var wins: Long? = null
    var losses: Long? = null
    var draws: Long? = null
}

And this is the code that triggers the data insertion:

    private fun createSync() {
        runBlocking {
            try {
                val user = app.currentUser
                if (user != null) {
                    val config = SyncConfiguration.Builder(
                        user = user,
                        partitionValue = "123456789",
                        schema = setOf(Users::class)
                    ).build()
                    val realm = Realm.open(config)
                    val currentUser = Users().apply {
                        name = "MyName"
                    }
                    realm.write {
                        copyToRealm(currentUser)
                    }
                } else {
                    Log.d("PreparationScreen", "User Null")
                }
            } catch (e: Exception) {
                Log.d("PreparationScreen", "$e")
            }
        }
    }

Also I cannot see any log that prints the error message about the realm sync. How can I achieve that?

Any help with this issue please?