Migration Lab, test passed, status page error [SOLVED]

I’ve been trying to find a solution for a while, I’ve checked all the discussions here but I can’t seem to find a solution to this problem.

The script finds 45993 documents and updates them. On MongoDB Compass the Schema tab says that all “lastupdated” fields are dates.

I tried to convert to string and back to date multiple times without success. I’m always stuck in the same situation, test passes, but status page says “Migration: It does not appear that you correctly converted the type”.

It just seems wrong to me, am I really missing something?

Found the solution here: Ticket Migration testing passed, but not getting validation number! [Solved]

In a previous chapter I have projected out the “lastupdated” property in the getMovieByID function by mistake (the tests and status of that stage didn’t show any problems). This also caused a strange behavior when loading a movie page, the info would suddenly disappear from the screen a short time after the page was loaded.
This also caused the Migration status to fail.
I hope his information can be helpful to someone who’s stuck in that same situation.


Glad to hear @Damian_Florin_50669! :slight_smile:

Good Luck!


1 Like