M320 Validator crashes Mac OS Big Sur

Hi.
Every time I run a command on the m320_validator it crashes my Mac. By that I mean it freezes Finder with the loading icon permanently showing and Finder becoming unusable. I am left having to restart my laptop. Restarting also does not work and I have to manually turn off my Mac and restart it.
I am using Big Sur v11.5.1.
I have tried the following:

  • delete and download again the validator
  • I have followed the guide on enabling permissions and allowing the app to run on the Mac via security & privacy
  • I have switched from zsh to bash

I would really appreciate some help.

If anyone faces this issue, it seems to be happening only on Mac OS Big Sur 11.5.1. It has been validated as working fine on 11.4.
The way I overcame the issue is to run a Vagrant environment as directed in the MongoDB University course M312 Chapter 1.
Please note that the Vagrant environment is running Linux so you will have to download the Linux version of the validator file.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.