M312 - Vagrant plugin install error

Doing Vagrant setup for M312 and getting this error:
Line number: 0
Message: RuntimeError: can’t modify frozen String

I have setup vagrant previously for another class with no issues.

Thanks for suggestions.


What OS are you using? If you can give me some additional information, I’ll try to help.

Also, is this a new Vagrant installation or are you re-using the one you installed previously? LMK.

Thanks David.

I had installed Vagrant for another Mongo DB course. So, I thought all I need to get done is what is outlined in the courseware(lab).

Despite uninstalled vagrant and re-installed it again, still go the same error. Finally I compare the vagrantfile between the two course and I added this IF logic and it worked.

From M103:

if Vagrant::VERSION < “2.0.0”

$stderr.puts “Must redirect to new repository for old Vagrant versions”



From M312:




1 Like


Thanks. That update should be (or should have been anyway) in the latest download. That was a known bug that was fixed in the last version of this course. I’ll check it out and get it fixed. Thanks for reporting this. Good luck.

Thank you for this information. I had the same issue.