M220P Chapter 0 setup

When I run python run.py I get the following:

(mflix) bossmandave@Davids-MacBook-Pro mflix-python % python run.py
Traceback (most recent call last):
  File "run.py", line 1, in <module>
    from mflix.factory import create_app
  File "/Users/bossmandave/Desktop/mflix-python/mflix/factory.py", line 3, in <module>
    from flask import Flask, render_template
ModuleNotFoundError: No module named 'flask'
(mflix) bossmandave@Davids-MacBook-Pro mflix-python % 

How do I fix this issue?

Please search our forum threads.There are many which discuss about activating conda/virtual environment,running requirements.txt,python version issues etc

1 Like

Hi :wave:@David_Thompson ,

ModuleNotFoundError: No module named 'flask'

Isn’t this the same error you were getting when you posted recently and resolved successfully:

Along with Ramachandra’s suggestion, I would also highly recommend you to check this old post of yours to see if there’s possibly anything that you missed this time since the error is the same. Did you install all the packages listed in the requirements.txt file and they were all installed without any errors?

Additionally, I remember there are multiple versions of python installed in your system. Do check if the conda environment is created with the right python version and all packages are installed with it only.

Regards,
Satyam

1 Like

Thanks… I will check prior posts… But I have a question. According to what I have read, I can have python version 10.2 installed on my system (which I do) and use the anaconda navigator (which comes with the anaconda install) to set up the mflix environment on a prior version of python (my understanding is it is possible because anaconda is a virtual environment)… So… I will check the installation of my requirements.txt file and redo…

Well… I am completely lost… @Satyam , you are correct. I thought I had python version 3.10 installed, but when I run ls -ls /usr/bin/python I get the following output.

bossmandave@Davids-MacBook-Pro ~ % ls -ls /usr/bin/python
0 lrwxr-xr-x  1 root  wheel  75 Dec  8 07:39 /usr/bin/python -> ../../System/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7
bossmandave@Davids-MacBook-Pro ~ % 

So… it appears that I am still using 2.7 (the default version that comes on the macbook pro).

Where I am confused is if I type python3 --version I get the following:

bossmandave@Davids-MacBook-Pro ~ % python3 --version
Python 3.10.2
bossmandave@Davids-MacBook-Pro ~ % 

This leads me to believe I HAVE python 3 installed, but my path is still using python 2.7… Is this correct?

To avoid more and more confusion… Where do I need to go to look at what version of Python I am ACTUALLY using?

Hey @David_Thompson,

As pointed out by you in your earlier post, you can use anaconda easily to create environments when you have multiple versions of python installed. I am linking your solution here for you.

I would suggest you follow along with the lab instructions and your old post to set up successfully again. :smile:

Regards,
Satyam

@Satyam I have done that but I continue to get the flask error. I reinstalled my OS to get rid of Python 3.10…

Now when I run python -version I get

bossmandave@Davids-MacBook-Pro mflix-python % python --version
Python 2.7.18

and when I run python3 --version I get

bossmandave@Davids-MacBook-Pro mflix-python % python3 --version
Python 3.8.12

I run the pip3 install -r requirements.txt and I get

(mflix) bossmandave@Davids-MacBook-Pro mflix-python % pip3 install -r requirements.txt
DEPRECATION: Configuring installation scheme with distutils config files is deprecated and will no longer work in the near future. If you are using a Homebrew or Linuxbrew Python, please see discussion at https://github.com/Homebrew/homebrew-core/issues/76621
Requirement already satisfied: appnope==0.1.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 1)) (0.1.0)
Requirement already satisfied: attrs==19.1.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 2)) (19.1.0)
Requirement already satisfied: backcall==0.1.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 3)) (0.1.0)
Requirement already satisfied: bcrypt==3.1.7 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 4)) (3.1.7)
Requirement already satisfied: bleach==3.1.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 5)) (3.1.0)
Requirement already satisfied: cffi==1.13.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 6)) (1.13.1)
Requirement already satisfied: Click==7.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 7)) (7.0)
Requirement already satisfied: decorator==4.4.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 8)) (4.4.0)
Requirement already satisfied: defusedxml==0.6.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 9)) (0.6.0)
Requirement already satisfied: dnspython==1.15.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 10)) (1.15.0)
Requirement already satisfied: entrypoints==0.3 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 11)) (0.3)
Requirement already satisfied: Faker==0.8.13 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 12)) (0.8.13)
Requirement already satisfied: flake8==3.7.8 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 13)) (3.7.8)
Requirement already satisfied: Flask==0.12.4 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 14)) (0.12.4)
Requirement already satisfied: Flask-Bcrypt==0.7.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 15)) (0.7.1)
Requirement already satisfied: Flask-Cors==3.0.3 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 16)) (3.0.3)
Requirement already satisfied: Flask-JWT-Extended==3.7.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 17)) (3.7.0)
Requirement already satisfied: Flask-Login==0.4.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 18)) (0.4.0)
Requirement already satisfied: importlib-metadata==0.23 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 19)) (0.23)
Requirement already satisfied: ipykernel==5.1.3 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 20)) (5.1.3)
Requirement already satisfied: ipython==7.8.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 21)) (7.8.0)
Requirement already satisfied: ipython-genutils==0.2.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 22)) (0.2.0)
Requirement already satisfied: ipywidgets==7.5.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 23)) (7.5.1)
Requirement already satisfied: itsdangerous==1.1.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 24)) (1.1.0)
Requirement already satisfied: jedi==0.15.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 25)) (0.15.1)
Requirement already satisfied: Jinja2==2.10.3 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 26)) (2.10.3)
Requirement already satisfied: jsonschema==3.1.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 27)) (3.1.1)
Requirement already satisfied: jupyter==1.0.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 28)) (1.0.0)
Requirement already satisfied: jupyter-client==5.3.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 29)) (5.3.1)
Requirement already satisfied: jupyter-console==6.0.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 30)) (6.0.0)
Requirement already satisfied: jupyter-core==4.4.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 31)) (4.4.0)
Requirement already satisfied: MarkupSafe==1.1.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 32)) (1.1.1)
Requirement already satisfied: mccabe==0.6.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 33)) (0.6.1)
Requirement already satisfied: mistune==0.8.4 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 34)) (0.8.4)
Requirement already satisfied: more-itertools==7.2.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 35)) (7.2.0)
Requirement already satisfied: nbconvert==5.6.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 36)) (5.6.0)
Requirement already satisfied: nbformat==4.4.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 37)) (4.4.0)
Requirement already satisfied: notebook==6.0.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 38)) (6.0.1)
Requirement already satisfied: pandocfilters==1.4.2 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 39)) (1.4.2)
Requirement already satisfied: parso==0.5.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 40)) (0.5.1)
Requirement already satisfied: pexpect==4.7.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 41)) (4.7.0)
Requirement already satisfied: pickleshare==0.7.5 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 42)) (0.7.5)
Requirement already satisfied: pluggy==0.6.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 43)) (0.6.0)
Requirement already satisfied: prometheus-client==0.7.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 44)) (0.7.1)
Requirement already satisfied: prompt-toolkit==2.0.10 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 45)) (2.0.10)
Requirement already satisfied: ptyprocess==0.6.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 46)) (0.6.0)
Requirement already satisfied: py==1.8.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 47)) (1.8.0)
Requirement already satisfied: pycodestyle==2.5.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 48)) (2.5.0)
Requirement already satisfied: pycparser==2.19 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 49)) (2.19)
Requirement already satisfied: pyflakes==2.1.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 50)) (2.1.1)
Requirement already satisfied: Pygments==2.4.2 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 51)) (2.4.2)
Requirement already satisfied: PyJWT==1.7.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 52)) (1.7.1)
Requirement already satisfied: pymongo==3.7.2 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 53)) (3.7.2)
Requirement already satisfied: pyrsistent==0.15.4 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 54)) (0.15.4)
Requirement already satisfied: pytest==3.3.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 55)) (3.3.0)
Requirement already satisfied: pytest-flask==0.11.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 56)) (0.11.0)
Requirement already satisfied: python-dateutil==2.8.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 57)) (2.8.0)
Requirement already satisfied: pyzmq==18.1.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 58)) (18.1.1)
Requirement already satisfied: qtconsole==4.5.5 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 59)) (4.5.5)
Requirement already satisfied: Send2Trash==1.5.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 60)) (1.5.0)
Requirement already satisfied: six==1.12.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 61)) (1.12.0)
Requirement already satisfied: terminado==0.8.2 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 62)) (0.8.2)
Requirement already satisfied: testpath==0.4.2 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 63)) (0.4.2)
Requirement already satisfied: text-unidecode==1.2 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 64)) (1.2)
Requirement already satisfied: tornado==6.0.3 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 65)) (6.0.3)
Requirement already satisfied: traitlets==4.3.3 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 66)) (4.3.3)
Requirement already satisfied: wcwidth==0.1.7 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 67)) (0.1.7)
Requirement already satisfied: webencodings==0.5.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 68)) (0.5.1)
Requirement already satisfied: Werkzeug==0.16.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 69)) (0.16.0)
Requirement already satisfied: widgetsnbextension==3.5.1 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 70)) (3.5.1)
Requirement already satisfied: zipp==0.6.0 in /usr/local/lib/python3.8/site-packages (from -r requirements.txt (line 71)) (0.6.0)
Requirement already satisfied: setuptools>=18.5 in /usr/local/lib/python3.8/site-packages (from ipython==7.8.0->-r requirements.txt (line 21)) (57.4.0)
DEPRECATION: Configuring installation scheme with distutils config files is deprecated and will no longer work in the near future. If you are using a Homebrew or Linuxbrew Python, please see discussion at https://github.com/Homebrew/homebrew-core/issues/76621
(mflix) bossmandave@Davids-MacBook-Pro mflix-python % 

To me this would suggest that I have successfully installed the requirements.txt items…

But when I run python run.py I get

(mflix) bossmandave@Davids-MacBook-Pro mflix-python % python run.py          
Traceback (most recent call last):
  File "run.py", line 1, in <module>
    from mflix.factory import create_app
  File "/Users/bossmandave/Desktop/mflix-python/mflix/factory.py", line 3, in <module>
    from flask import Flask, render_template
ImportError: No module named flask
(mflix) bossmandave@Davids-MacBook-Pro mflix-python % 

So as far a looking at my prior posts and following the setup… It seems to be done. The only things I have had to change is the map for my conda terminal. In the lab it says to type

echo ". /anaconda3/etc/profile.d/conda.sh" >> ~/.bash_profile
source ~/.bash_profile

However I has to add to the command. I had to type
echo “./Users/bossmandave/anaconda/anaconda3/etc/profile.d/conda.sh”

The next step is for me to create the mflix environment. Does this different path make any difference in the procedures after?

In addition because the course is designed to use 3.8, I had to replace the pip install command with pip3 install…

Does this make any difference?

found one of my problems… According to the lab it says to run python run.py… I believe once you use python 3.8, you need to replace this with python3 run.py.

This command changes my entire error.

I run python3 run.py and I get the following error

(mflix) bossmandave@Davids-MacBook-Pro mflix-python % python3 run.py
Traceback (most recent call last):
  File "run.py", line 13, in <module>
    app.config['MFLIX_DB_URI'] = config['PROD']['MFLIX_DB_URI']
  File "/usr/local/Cellar/python@3.8/3.8.12_1/Frameworks/Python.framework/Versions/3.8/lib/python3.8/configparser.py", line 960, in __getitem__
    raise KeyError(key)
KeyError: 'PROD'
(mflix) bossmandave@Davids-MacBook-Pro mflix-python % 

This is different from the flask error… Where do I go from here?

Found my problem… I forgot to change my ini file… Now I can get the lab setup to pass… Going to see if the lab ticket can pass.

Still getting the access denied to local host… But I can run all tests and I can start the program. below is what I get.

(mflix) bossmandave@Davids-MacBook-Pro mflix-python % pytest -m connection
============================= test session starts ==============================
platform darwin -- Python 3.8.12, pytest-3.3.0, py-1.8.0, pluggy-0.6.0
rootdir: /Users/bossmandave/Desktop/mflix-python, inifile: pytest.ini
plugins: flask-0.11.0
collected 43 items                                                             

tests/test_db_connection.py ....                                         [100%]

============================= 39 tests deselected ==============================
=================== 4 passed, 39 deselected in 1.05 seconds ====================
(mflix) bossmandave@Davids-MacBook-Pro mflix-python %

The connection test passes… Then when I run the program and try to go to the page on the ticket… I get access denied.

(mflix) bossmandave@Davids-MacBook-Pro mflix-python % python3 run.py
 * Running on http://127.0.0.1:5000/ (Press CTRL+C to quit)
 * Restarting with stat
 * Debugger is active!
 * Debugger PIN: 688-592-946

when I click on the status page link in the ticket… I get the following screen.

So… I am now running it right, but I cannot access the page… Any ideas?

Are you able to access the URL mentioned and open this page?

If this is opening, you’ll see a status button on there as shown in the picture:

Regards,
Satyam

Is it being sourced properly?
There is no space between dot (. ) and /Users

1 Like

@Satyam no… I get the access denied page… HTTP error 403

Running python3 run.py tells

so try 127.0.0.1:5000 rather than localhost:5000.

1 Like

@steevej , I just noticed something… when I am doing the README setup Mflix section, when I create the mflix environment, I can use the conda activate mflix command.

When I quit the terminal and open another one, I cannot execute the conda activate mflix… I get the following.

bossmandave@Davids-MacBook-Pro ~ % cd Desktop/mflix-python
bossmandave@Davids-MacBook-Pro mflix-python % conda activate mflix
Could not find conda environment: mflix
You can list all discoverable environments with `conda info --envs`.

bossmandave@Davids-MacBook-Pro mflix-python % 

if I list the environments I get the following:

bossmandave@Davids-MacBook-Pro mflix-python % conda info --envs      
# conda environments:
#
                         /Users/bossmandave/anaconda/anaconda3
                         /Users/bossmandave/anaconda/anaconda3/envs/mflix
base                  *  /Users/bossmandave/opt/anaconda3

bossmandave@Davids-MacBook-Pro mflix-python % 

It appears that the base is in the /opt/anaconda3 and my environment is in the anaconda/anaconda3… How do I correct this?

@steevej @Satyam , I corrected my conda problem by mapping to
/Users/bossmandave/opt/anaconda3/etc/…

This now creates the conda environment in the right directory. However I still get the access denied when trying to connect to localhost…

as well as trying to connect to the status page link on the lab 0 ticket.

@steevej @Satyam
I am looking at this and it appears I have anaconda installed in two places on my computer…

If I run ls -ls on ./anaconda/anaconda3 I get the following:

bossmandave@Davids-MacBook-Pro ~ % ls -ls ./anaconda/anaconda3
total 48
 0 drwxr-xr-x     3 bossmandave  wheel     96 Jan 16 13:54 Anaconda-Navigator.app
24 -rw-r--r--     1 bossmandave  wheel  11440 Nov  9 23:53 LICENSE.txt
 0 drwxr-xr-x   469 bossmandave  wheel  15008 Feb  7 11:12 bin
 0 drwxr-xr-x   376 bossmandave  wheel  12032 Feb  7 11:12 conda-meta
 0 drwxr-xr-x     3 bossmandave  wheel     96 Jan 17 13:56 condabin
 0 drwxr-xr-x     3 bossmandave  wheel     96 Jan 16 13:53 doc
 0 drwxrwxr-x     4 bossmandave  wheel    128 Feb 17 16:20 envs
 0 drwxr-xr-x     5 bossmandave  wheel    160 Jan 16 13:54 etc
 0 drwxr-xr-x   365 bossmandave  wheel  11680 Jan 16 13:54 include
 0 drwxr-xr-x   774 bossmandave  wheel  24768 Feb  7 11:12 lib
 0 drwxr-xr-x     4 bossmandave  wheel    128 Jan 16 13:54 libexec
 0 drwxr-xr-x     3 bossmandave  wheel     96 Jan 16 13:53 licensing
 0 drwxr-xr-x     3 bossmandave  wheel     96 Jan 16 13:53 man
 0 drwxr-xr-x    68 bossmandave  wheel   2176 Jan 16 13:54 mkspecs
 0 drwxr-xr-x    15 bossmandave  wheel    480 Jan 16 13:54 phrasebooks
 0 drwxr-xr-x  1508 bossmandave  wheel  48256 Feb 17 16:17 pkgs
 0 drwxr-xr-x    26 bossmandave  wheel    832 Jan 16 13:54 plugins
24 -rw-rw-r--     2 bossmandave  wheel  11518 Jul  4  2021 pyodbc.pyi
 0 drwxr-xr-x     3 bossmandave  wheel     96 Jan 16 13:54 python.app
 0 drwxr-xr-x    27 bossmandave  wheel    864 Jan 16 13:54 qml
 0 drwxr-xr-x     7 bossmandave  wheel    224 Jan 16 13:54 resources
 0 drwxr-xr-x    14 bossmandave  wheel    448 Jan 16 13:53 sbin
 0 drwxr-xr-x    20 bossmandave  wheel    640 Feb  7 11:12 share
 0 drwxr-xr-x     3 bossmandave  wheel     96 Jan 16 13:54 shell
 0 drwxr-xr-x     9 bossmandave  wheel    288 Feb  7 11:12 ssl
 0 drwxr-xr-x   290 bossmandave  wheel   9280 Jan 16 13:54 translations

If I run that same command on ./opt/anaconda3 I get the following:

bossmandave@Davids-MacBook-Pro ~ % ls -ls ./opt/anaconda3
total 56
 0 drwxr-xr-x     3 bossmandave  staff     96 Feb  7 11:24 Anaconda-Navigator.app
24 -rw-r--r--     1 bossmandave  staff  11440 Nov  9 23:53 LICENSE.txt
 0 drwxr-xr-x   467 bossmandave  staff  14944 Feb 12 23:14 bin
 0 drwxr-xr-x   377 bossmandave  staff  12064 Feb 12 23:14 conda-meta
 0 drwxr-xr-x     3 bossmandave  staff     96 Feb  7 11:57 condabin
 0 drwxr-xr-x     3 bossmandave  staff     96 Feb  7 11:24 doc
 0 drwxrwsr-x     4 bossmandave  staff    128 Feb 18 13:25 envs
 0 drwxr-xr-x     5 bossmandave  staff    160 Feb  7 11:24 etc
 0 drwxr-xr-x   366 bossmandave  staff  11712 Feb 12 23:14 include
 0 drwxr-xr-x   780 bossmandave  staff  24960 Feb 12 23:14 lib
 0 drwxr-xr-x     4 bossmandave  staff    128 Feb  7 11:24 libexec
 0 drwxr-xr-x     3 bossmandave  staff     96 Feb  7 11:24 licensing
 0 drwxr-xr-x     3 bossmandave  staff     96 Feb  7 11:24 man
 0 drwxr-xr-x    68 bossmandave  staff   2176 Feb  7 11:24 mkspecs
 0 drwxr-xr-x    15 bossmandave  staff    480 Feb  7 11:24 phrasebooks
 0 drwxr-xr-x  1289 bossmandave  staff  41248 Feb 12 23:14 pkgs
 0 drwxr-xr-x    26 bossmandave  staff    832 Feb  7 11:24 plugins
32 -rw-rw-r--     2 bossmandave  staff  13102 Aug 20  2021 pyodbc.pyi
 0 drwxr-xr-x     3 bossmandave  staff     96 Feb  7 11:24 python.app
 0 drwxr-xr-x    27 bossmandave  staff    864 Feb  7 11:24 qml
 0 drwxr-xr-x     7 bossmandave  staff    224 Feb  7 11:24 resources
 0 drwxr-xr-x    14 bossmandave  staff    448 Feb  7 11:24 sbin
 0 drwxr-xr-x    19 bossmandave  staff    608 Feb 12 23:14 share
 0 drwxr-xr-x     3 bossmandave  staff     96 Feb  7 11:24 shell
 0 drwxr-xr-x     9 bossmandave  staff    288 Feb 12 23:14 ssl
 0 drwxr-xr-x   290 bossmandave  staff   9280 Feb  7 11:24 translations
bossmandave@Davids-MacBook-Pro ~ % 

This appears to be an exact copy… I am not going to until I hear back from on of you, but I’m inclined to delete the anaconda folder and its contents. I think this may eliminate any confusion.

@steevej @Satyam ,

Ok… I think I am almost there… I mapped the conda terminal command to the /opt/anaconda, and I modified my .ini file to include the sample_mflix at the end of my connection string.

Here is where I am… on Chapter 0, Ticket Connection, on the link for the status page, I get the local host access denied… however when I type in 127.0.0.1:5000 I can connect.

Do I even need to correct this or can I now continue with the course???

127.0.0.1:5000

Using the link on the ticket for the status page

1 Like

Hey @David_Thompson,

You open the status page using The STATUS button on the right-hand side of the screen of 127.0.0.0:5000.

Let us know if you are able to access the status page using this way or not.

Regards,
Satyam

1 Like

@Satyam ,
Yes. using 127.0.0.1:5000 I can open the status page and I can get the status to come up.

Can I continue with the course?