M220 can connect with mongoshell but not with app

I’m trying to set up the app for the M220 course for js developer.

I’ve followed the readme instructions and i can connect to the DB through the MongoShell correctly. On the MongoShell I see the collections and the items.

But I cannot connect true the app, if I run npm start, the movie list section is empty (the icon keeps spinning).

If I run the npm test -t connection-pooling command I got this error
Connection Pooling › Connection pool size is 50

expect(received).toBe(expected) // Object.is equality

Expected: 50
Received: undefined


  Comparing two different types of values. Expected number but received undefined.

   8 |   test("Connection pool size is 50", async () => {
   9 |     const response = await MoviesDAO.getConfiguration()
> 10 |     expect(response.poolSize).toBe(50)
     |                               ^
  11 |   })
  12 | })
  13 | 

  at toBe (test/connection-pooling.test.js:10:31)
  at tryCatch (node_modules/regenerator-runtime/runtime.js:62:40)
  at Generator.invoke [as _invoke] (node_modules/regenerator-runtime/runtime.js:296:22)
  at Generator.prototype.(anonymous function) [as next] (node_modules/regenerator-runtime/runtime.js:114:21)
  at step (node_modules/babel-runtime/helpers/asyncToGenerator.js:17:30)
  at node_modules/babel-runtime/helpers/asyncToGenerator.js:28:13

Could someone pls help me?

I’ve made several errors in setupping the DB. PLS delete this topic :slight_smile:

That is the expected behavior for the connection pooling test because we have not gotten to that point. The test is supposed to fail.

What were the errors?

I’m having the same issues.