M201 - Lab 1.1: Install Course Tools and Datasets

I am unable to import m201 people.json dataset
I connect to my MacOS MongoDB shell to my Atlas private cluster using

mongo mongodb+srv://m001-student:m001-mongodb-basics@Sandbox.ick6v.mongodb.net/test

and once on the PRIMARY prompt, i run mongoimport using below command, but nothing happens

mongoimport --drop -c people --uri mongodb+srv://m001-student:m001-mongodb-basics@Sandbox.ick6v.mongodb.net/m201 people.json

Where I am getting it wrong?

You should not run mongoimport inside the mongo shell.

What ever terminal you use when you run

that is where you need to run

I understand there are 3 ways to connect to a cluster
Shell
Compass
Application thru drivers

Is there some other terminal that can be used

Are you still facing issue with mongoimport?
Just exit from mongoprompt and you will be at your os prompt
Run from there

Those are the three methods to connect to your cluster
For basics and cluster admin course there is a IDE environment but not for this course

1 Like

It worked. Thanks Ramachandra