M150 : chapter 3: Internal Authentication learning activity: Implementing internal Authentication

HI,
I need to start 3 mongod processes using each of the
configuration files. I need to start each replica set member with the new configuration.
On IDE I have “user@m150#” displayed.
To start a mongod process I Type the followings
1- mongod -f mongod_1.conf
which didn’t work.
2- mongo --host localhost:27001
which didn’t work.
3-mongo
didn’t work.
how can I start a mongod process on IDE?

Hi @farideh_gorji,
If you want to start a mongod process you need to run the following command only:

Can you share the error message that you get when you run the above command?

If you have any doubts, please feel free to reach out to us.

Thanks and Regards.
Sourabh Bagrecha,
MongoDB


I think you are missing slash before var in your keyfile path

1 Like


I followed the lecture of chapter 3 but in the lecture note I have
the followings
security:
keyFile: /var/mongodb/pki/1/mongod-keyfile
and
mongod -f mongod1-auth.conf

Do you have all dbpath,logpath,keyfile dirs exist and keyfile with proper permissions?
Try to run by commenting fork as per the message you are getting.
It will show why it is failing
Does mongod.log show more details?

I followed the lecture of chapter 3 but in the lecture note I have
the followings
security:
keyFile: /var/mongodb/pki/1/mongod-keyfile
and
mongod -f mongod1-auth.conf
[/quote]

What is the result without fork option?
Are you using the correct config files?
Your snapshot shows mongod_1.conf but your description shows mongod1-auth.conf?

Thank you very much for trying to help.
It worked.
The keyFile: must be /var/mongodb/pki/node2/keyfile
instead of /var/mongod/pki/node2/keyfile.
best wishes
Farideh

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.