M121 dont connect

I am trying to connect at M121 - aggregations, but I received an error:

I uses Mongosh, CMD and Compass

“mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

I got an error in all this cases.
How can I connect?

It’s probably a problem with the quotation marks. Try this:

mongosh "mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0" --authenticationDatabase admin --ssl -u m121 -p aggregations --norc
1 Like

I try your string on Compass and I got this error: TLS/SSL is disabled. If possible, enable TLS/SSL to avoid security vulnerabilities.

Try again using Mongosh and I got this error:
MongoshInvalidInputError: [COMMON-10001] Invalid URI: mongosh “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

Can you share a screenshot of how you are trying to connect with mongosh?

To connect with Compass, you should indeed make some changes, as with that mongosh command you are passing the TLS option (--ssl) and authentication information (-u and -p) as arguments.

After pasting the connection string into Compass, you can make the following changes by expanding the “Advanced Options”

3 Likes