M121 chapter 0 : how to connect to mongo

Hi,
The video of chapter 0 of m121 is trying to explain how to install the MongoDB Enterprise. I had difficulty installing that, because the video is old and the pages of mongodb.com has been changed . I was told to install the Community version of MongoDB. The lecturer says type "mongo mongodb://cluster0-shard00-00-jxqq-------
to connect to the atlas cluster. I don’t know what to do? please tell me step by step what to do. for m001 and m103 we had the mongo shell installed. all the steps explained on lecture 0 is not helpful because the page mongodb.com has been changed.

I don’t think you need entp edition for this course.Just shell is enough
If you already have shell on your PC or laptop just connect using the connect string for m121 course

hi, I have mongosh-1.3.1-x64 available on the Web .Would that be ok? . When I choose the “I have mongo installed” on Atlas , the Atlas doesn’t offer this version to choose. Would that be ok to unzip into the 121 directory? I have windows 10 for 64 bits installed.

You must be already having shell on your pc from previous courses
What is this zip file you are trying to install?

I have MongoDB compass on my pc which the connection string can’t be copied and pasted, I don’t know what the problem is. For the courses m103 and m001 we had IDE
available. We used IDE environment. Even now I tried to enter the 103 course, and copied the connection string of 121 there it worked but there is a warning that the server number does not match.

Please tell me how can I have the right version of mongo on my pc to be accepted by Atlas?

If you are connected it is enough
Please ignore version mismatch messages

When you open Compass by default it will show last connected string
Choose new connection and paste the m121 string
or click edit existing connection string erase it and paste your new string


I tried to connect via MongoDB compass. I received this message.
would you please help to resolve the problem?

Have you whitelisted your IP or allow access from anywhere?

Hi, for the m121 course we must connect to mongo shell using a connection string.
For this course IDE environment is not available. So I must install The mongo Shell via Atlas cluster. In which I need a lot of your help.

From Atlas I chose “connect” Then I chose “I don’t have The MongoDB shell Installed”.
I chose “windows” then “download Mongosh(5.3.1)”. Mongosh-1.3.1-win32-x64.zip is downloaded. I have windows 10 for 64 bits installed on my pc. Atlas tells us step 2 - add your mongosh download directory> /bin to your $path variable. In which I need your help. I also have mongosh-1.3.1-x64 msi available on my pc.
would you please give me a definite lead let me know just what to do?

Try to install 64bit msi
After installing update your system variable path with full path of bin dir
Try to search our forum threads on how to update path on Windows

1 Like

Hi @farideh_gorji,
Can you please confirm if your installation and configuration have been resolved now?
If so, can you share what worked for you and what did not?
If not, please feel free to reach out to us with any doubts or concerns you may have faced.

Thanks and Regards.
Sourabh Bagrecha,
Curriculum Services Engineer

1 Like

Hi,
Thanks for your cooperation. Yes my installation has been resolved now.
I will share what worked for me and what did not with others.
1- go to mongodb.com
2- go to Atlas
3- choose connect
4- choose “I don’t have mongo installed.”
Here if you click on “Download mongosh(5.3.1), the mongo-1.3.1 win32-x64.zip will be installed.
I have windows10 64 bits installed on my pc. This was not the right choice for me.
on the same page click on “How to”
2-add <your mongosh’s download directory>bin to your $path variable.” How to"
3- On the new page opened go to “Install from MSI”
4- Open the "MongoDB Download Center "
here you can download mongo shell for 64 bits(8.1+)(MSI).
mongosh-1.3.1x64 will be downloaded.
5- click on the downloaded file and follow the direction
6- change the connecting string of Atlas for the “m121 course” from
“mongo” to “mongosh”
no configuration is necessary for the MSI version of mongo shell.
Thanks and Regards
Farideh

1 Like