M103: Vagrant virtual machine not working

I have tried everything suggested in the forum trying to get vagrant virtual machines runnig (M040 and M103), but I cannot continue the courses that involve Vagrant because it does not work at all.

I disabled the Hyper-V, in the BIOS the virtualization support is active, however the error continues. I have tried the vagrant up --debug, but the same happens.

System OS: Windows 10 Pro.

PS C:\Users\Vladimir\MongoDB\M103\m103-vagrant-env> vagrant up
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Importing base box ‘ubuntu/trusty64’…
==> mongod-m103: Matching MAC address for NAT networking…
==> mongod-m103: Setting the name of the VM: mongod-m103
==> mongod-m103: Clearing any previously set forwarded ports…
==> mongod-m103: Clearing any previously set network interfaces…
==> mongod-m103: Preparing network interfaces based on configuration…
mongod-m103: Adapter 1: nat
mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports…
mongod-m103: 22 (guest) => 2222 (host) (adapter 1)
==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“startvm”, “ac7fe741-941b-416e-804e-669bace0b01d”, “–type”, “headless”]

Stderr: VBoxManage.exe: error: (VERR_NEM_MISSING_KERNEL_API).
VBoxManage.exe: error: VT-x is not available (VERR_VMX_NO_VMX)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component ConsoleWrap, interface IConsole

Did you try to restart your system?

This may help

VM Start error on Windows 10 pro

1 Like

Yes, I restarted the system, checked the BIOS, Hyper-V is disabled, but the problem is still there.

Did your try vagrant halt
then vagrant provision

If nothing works you may have to destroy and reinstall
Please check our forums

1 Like

Hi @vladimirrav,

Did you try to enable virtualization in the BIOS?


Yes, I did try the vitrualization option in the BIOS, it’s active.
The vagrant --halt option didn’t work either.
I have tried reinstalling the vagrant and virtualbox, but the problem is the same.