M103 :Please help to correct the error

Hi, thanks for all the help. I am trying to run my configuration file. There is an error .
Would you please tell me what the problem is?

. There are three lines of comments and then some part of my code.

Remove the space before systemLog
Use only space bar.Do not use tab
storage,systemLog,net all should be inline (align them properly by removing spaces)
No need to pass port in your command if it is already included under net
We cannot see full config file

Hi Ramchandra:
Thanks for your kindness . Since you asked to see full config file:

does fork work in windows 10? this is my last try.

Please check your lab requirements
You added lot of parameters like keyfile,bindip which are not needed
Just add only those asked for
YAML is very picky
You have to take care of indentation,spaces etc
Remove everything and only those parameters asked for in the lab
There is no fork in Windows


Please help me to correct and fix the error.?

Is your mongod up and running on port 27000?
Looks like your command to connect to mongod with --eval is not complete
It connected to mongod(">’) you are at mongo prompt and you are trying to run mongo command again
You should run mongo command at terminal prompt(os promp)
Exit and try again your user creation command with eval

Dear Ramachandra:
I added the user successfully, but on the lectures is not shown how to enable the authentication and how to set the port to 27000 inside the cofiguration file, I have used
mongod --port 27000 --auth . THose references which are mentioned on the lectures as reference /configuration -options and reference/program /mongod are not accessible.
do you accept command line options

for the port and auth?

Is there any other link to cofiguration options?

If your lab asks you to start mongod with config file it has to be started with config file else your test results will fail
There are so many threads and sample config files in our forum.Pick what you need from them and add it to your config file
Please refer to mongo documentation for different params

If you start the mongod using a configuration file, add the security.authorization configuration file setting:

authorization: enabled